#12 send list of packages on cloud images to spot for change from %doc to %license
Opened 5 years ago by mattdm. Modified 2 years ago


I added a list of packages that I could see from the kickstart. I did not include packages that we remove that we don't need from core. If you could just take a look at it and see if it's correct, that would be awesome. In the future, should I post the list of packages here, then we take a look at it and see if everything's good and then post to that ticket, or was the way I did it correct?

That way is fine -- thanks for looking at this.

I think we need the list including dependencies, though, so the easiest way is to actually log into a system and run rpm -qa --queryformat='%{sourcerpm}\n' | sort -u, which gives us this list of 173 packages on F20:

{{{
acl-2.2.52-4.fc20.src.rpm
attr-2.4.47-3.fc20.src.rpm
audit-2.3.4-1.fc20.src.rpm
basesystem-10.0-9.fc20.src.rpm
bash-4.2.45-4.fc20.src.rpm
bind-9.9.4-12.P2.fc20.src.rpm
bzip2-1.0.6-9.fc20.src.rpm
ca-certificates-2013.1.97-1.fc20.src.rpm
checkpolicy-2.1.12-5.fc20.src.rpm
chkconfig-1.3.60-4.fc20.src.rpm
cloud-init-0.7.2-7.fc20.src.rpm
cloud-utils-0.27-9.fc20.src.rpm
coreutils-8.21-21.fc20.src.rpm
cpio-2.11-24.fc20.src.rpm
cracklib-2.9.0-5.fc20.src.rpm
cronie-1.4.11-4.fc20.src.rpm
crontabs-1.11-7.20130830git.fc20.src.rpm
cryptsetup-1.6.4-1.fc20.src.rpm
curl-7.32.0-8.fc20.src.rpm
cyrus-sasl-2.1.26-14.fc20.src.rpm
dbus-1.6.12-8.fc20.src.rpm
device-mapper-multipath-0.4.9-56.fc20.src.rpm
dhcp-4.2.6-1.fc20.src.rpm
diffutils-3.3-4.fc20.src.rpm
dmidecode-2.12-4.fc20.src.rpm
dracut-034-64.git20131205.fc20.1.src.rpm
dtc-1.4.0-2.fc20.src.rpm
e2fsprogs-1.42.8-3.fc20.src.rpm
elfutils-0.158-1.fc20.src.rpm
expat-2.1.0-7.fc20.src.rpm
fedora-release-20-3.src.rpm
file-5.14-20.fc20.src.rpm
filesystem-3.2-19.fc20.src.rpm
findutils-4.5.11-4.fc20.src.rpm
fipscheck-1.4.1-2.fc20.src.rpm
freetype-2.5.0-5.fc20.src.rpm
gawk-4.1.0-2.fc20.src.rpm
gcc-4.8.2-7.fc20.src.rpm
gdbm-1.10-7.fc20.src.rpm
glib2-2.38.2-2.fc20.src.rpm
glibc-2.18-12.fc20.src.rpm
gmp-5.1.2-2.fc20.src.rpm
gnupg2-2.0.22-1.fc20.src.rpm
gpgme-1.3.2-4.fc20.src.rpm
grep-2.18-1.fc20.src.rpm
groff-1.22.2-8.fc20.src.rpm
grubby-8.28-1.fc20.src.rpm
gzip-1.6-2.fc20.src.rpm
hardlink-1.0-18.fc20.src.rpm
heat-cfntools-1.2.6-2.fc20.src.rpm
hostname-3.13-2.fc20.src.rpm
initscripts-9.51-2.fc20.src.rpm
iproute-3.12.0-2.fc20.src.rpm
iptables-1.4.19.1-1.fc20.src.rpm
iputils-20121221-5.fc20.src.rpm
jbigkit-2.0-9.fc20.src.rpm
json-c-0.11-3.fc20.src.rpm
kernel-3.11.10-301.fc20.src.rpm
kernel-3.13.7-200.fc20.src.rpm
keyutils-1.5.9-1.fc20.src.rpm
kmod-15-1.fc20.src.rpm
krb5-1.11.5-4.fc20.src.rpm
lcms-1.19-10.fc20.src.rpm
less-458-6.fc20.src.rpm
libassuan-2.1.0-2.fc20.src.rpm
libcap-2.22-7.fc20.src.rpm
libcap-ng-0.7.3-6.fc20.src.rpm
libcgroup-0.38-7.fc20.src.rpm
libdb-5.3.28-1.fc20.src.rpm
libedit-3.1-2.20130601cvs.fc20.src.rpm
libestr-0.1.9-1.fc20.src.rpm
libffi-3.0.13-5.fc20.src.rpm
libgcrypt-1.5.3-2.fc20.src.rpm
libgpg-error-1.12-1.fc20.src.rpm
libidn-1.28-2.fc20.src.rpm
libjpeg-turbo-1.3.0-2.fc20.src.rpm
libmetalink-0.1.2-4.fc20.src.rpm
libpipeline-1.2.4-2.fc20.src.rpm
libpng-1.6.3-3.fc20.src.rpm
libpwquality-1.2.3-1.fc20.src.rpm
libselinux-2.2.1-6.fc20.src.rpm
libsemanage-2.1.10-14.fc20.src.rpm
libsepol-2.1.9-2.fc20.src.rpm
libssh2-1.4.3-8.fc20.src.rpm
libtasn1-3.3-2.fc20.src.rpm
libtiff-4.0.3-14.fc20.src.rpm
libuser-0.60-3.fc20.src.rpm
libutempter-1.1.6-3.fc20.src.rpm
libverto-0.2.5-3.fc20.src.rpm
libwebp-0.3.1-2.fc20.src.rpm
libxml2-2.9.1-2.fc20.src.rpm
libyaml-0.1.5-1.fc20.src.rpm
linux-atm-2.5.1-8.fc20.src.rpm
linux-firmware-20140317-37.gitdec41bce.fc20.src.rpm
logrotate-3.8.7-1.fc20.src.rpm
lua-5.2.2-5.fc20.src.rpm
lvm2-2.02.103-5.fc20.src.rpm
man-db-2.6.5-2.fc20.src.rpm
mtools-4.0.18-4.fc20.src.rpm
ncurses-5.9-12.20130511.fc20.src.rpm
net-tools-2.0-0.15.20131119git.fc20.src.rpm
(none)
nspr-4.10.4-1.fc20.src.rpm
nss-3.16.0-1.fc20.src.rpm
nss-softokn-3.16.0-1.fc20.src.rpm
nss-util-3.16.0-1.fc20.src.rpm
openldap-2.4.39-2.fc20.src.rpm
openssh-6.4p1-3.fc20.src.rpm
openssl-1.0.1e-37.fc20.src.rpm
p11-kit-0.20.2-1.fc20.src.rpm
pam-1.1.8-1.fc20.src.rpm
parted-3.1-13.fc20.src.rpm
passwd-0.79-2.fc20.src.rpm
pcre-8.33-4.fc20.src.rpm
pinentry-0.8.1-11.fc20.src.rpm
pkgconfig-0.28-3.fc20.src.rpm
policycoreutils-2.2.5-3.fc20.src.rpm
popt-1.16-2.fc20.src.rpm
procps-ng-3.3.8-16.fc20.src.rpm
pth-2.0.7-21.fc20.src.rpm
pygpgme-0.3-8.fc20.src.rpm
pyliblzma-0.5.3-10.fc20.src.rpm
python-2.7.5-11.fc20.src.rpm
python-backports-1.0-3.fc20.src.rpm
python-backports-ssl_match_hostname-3.4.0.2-1.fc20.src.rpm
python-boto-2.25.0-2.fc20.src.rpm
python-chardet-2.0.1-7.fc20.src.rpm
python-cheetah-2.4.4-5.fc20.src.rpm
python-configobj-4.7.2-7.fc20.src.rpm
python-iniparse-0.4-9.fc20.src.rpm
python-IPy-0.75-6.fc20.src.rpm
python-markdown-2.3.1-3.fc20.src.rpm
python-pillow-2.2.1-3.fc20.src.rpm
python-prettytable-0.7.2-1.fc20.src.rpm
python-psutil-1.0.1-1.fc20.src.rpm
python-pycurl-7.19.3-1.fc20.src.rpm
python-pygments-1.6-1.fc20.src.rpm
python-requests-1.2.3-5.fc20.src.rpm
python-setuptools-1.4.2-1.fc20.src.rpm
python-six-1.4.1-1.fc20.src.rpm
python-urlgrabber-3.9.1-32.fc20.src.rpm
python-urllib3-1.7-4.fc20.src.rpm
pyxattr-0.5.1-4.fc20.src.rpm
PyYAML-3.10-9.fc20.src.rpm
qrencode-3.4.2-1.fc20.src.rpm
readline-6.2-8.fc20.src.rpm
rootfiles-8.1-16.fc20.src.rpm
rpm-4.11.2-2.fc20.src.rpm
rsync-3.1.0-2.fc20.src.rpm
rsyslog-7.4.8-1.fc20.src.rpm
sed-4.2.2-6.fc20.src.rpm
selinux-policy-3.12.1-135.fc20.src.rpm
setools-3.3.7-41.fc20.src.rpm
setup-2.8.71-2.fc20.src.rpm
shadow-utils-4.1.5.1-8.fc20.src.rpm
shared-mime-info-1.2-1.fc20.src.rpm
sqlite-3.8.4.2-1.fc20.src.rpm
sudo-1.8.8-1.fc20.src.rpm
syslinux-4.05-7.fc20.src.rpm
systemd-208-15.fc20.src.rpm
sysvinit-2.88-14.dsf.fc20.src.rpm
tar-1.26-30.fc20.src.rpm
tcp_wrappers-7.6-76.fc20.src.rpm
texinfo-5.1-4.fc20.src.rpm
tzdata-2014b-1.fc20.src.rpm
uboot-tools-2013.10-3.fc20.src.rpm
ustr-1.0.4-15.fc20.src.rpm
util-linux-2.24.1-1.fc20.src.rpm
vim-7.4.179-1.fc20.src.rpm
xz-5.1.2-6alpha.fc20.src.rpm
yum-3.4.3-137.fc20.src.rpm
yum-metadata-parser-1.1.4-9.fc20.src.rpm
zlib-1.2.8-3.fc20.src.rpm
}}}

I'd love to get that smaller, but that's where we are now....

After running the command on fedora 21 cloud image, i got following result with 170 packages

acl-2.2.52-7.fc21.src.rpm
attr-2.4.47-9.fc21.src.rpm
audit-2.4.1-1.fc21.src.rpm
basesystem-10.0-10.fc21.src.rpm
bash-4.3.30-2.fc21.src.rpm
bind-9.9.6-4.fc21.src.rpm
bzip2-1.0.6-14.fc21.src.rpm
ca-certificates-2014.2.1-1.5.fc21.src.rpm
checkpolicy-2.3-4.fc21.src.rpm
chkconfig-1.3.63-1.fc21.src.rpm
cloud-init-0.7.5-8.fc21.src.rpm
cloud-utils-0.27-12.fc21.src.rpm
coreutils-8.22-19.fc21.src.rpm
cpio-2.11-30.fc21.src.rpm
cracklib-2.9.1-5.fc21.src.rpm
cronie-1.4.12-1.fc21.src.rpm
crontabs-1.11-9.20130830git.fc21.src.rpm
crypto-policies-20140905-1.git4649b7d.fc21.src.rpm
cryptsetup-1.6.6-1.fc21.src.rpm
curl-7.37.0-9.fc21.src.rpm
cyrus-sasl-2.1.26-19.fc21.src.rpm
dbus-1.8.6-3.fc21.src.rpm
device-mapper-multipath-0.4.9-68.fc21.1.src.rpm
dhcp-4.3.1-8.fc21.src.rpm
diffutils-3.3-9.fc21.src.rpm
dmidecode-2.12-8.fc21.src.rpm
dracut-038-30.git20140903.fc21.src.rpm
e2fsprogs-1.42.11-4.fc21.src.rpm
elfutils-0.160-1.fc21.src.rpm
expat-2.1.0-10.fc21.src.rpm
fedora-release-21-2.src.rpm
fedora-repos-21-2.src.rpm
file-5.19-7.fc21.src.rpm
filesystem-3.2-27.fc21.src.rpm
findutils-4.5.12-7.fc21.src.rpm
fipscheck-1.4.1-7.fc21.src.rpm
gawk-4.1.1-5.fc21.src.rpm
gcc-4.9.2-1.fc21.src.rpm
gdbm-1.11-4.fc21.src.rpm
glib2-2.42.1-1.fc21.src.rpm
glibc-2.20-5.fc21.src.rpm
gmp-6.0.0-7.fc21.src.rpm
gnupg2-2.0.25-2.fc21.src.rpm
gpgme-1.4.3-4.fc21.src.rpm
grep-2.20-6.fc21.src.rpm
groff-1.22.2-11.fc21.src.rpm
grubby-8.35-8.fc21.src.rpm
gzip-1.6-5.fc21.src.rpm
hardlink-1.0-21.fc21.src.rpm
heat-cfntools-1.2.7-4.fc21.src.rpm
hostname-3.15-4.fc21.src.rpm
initscripts-9.56.1-4.fc21.src.rpm
iproute-3.16.0-3.fc21.src.rpm
iptables-1.4.21-13.fc21.src.rpm
iputils-20140519-4.fc21.src.rpm
kernel-3.17.4-301.fc21.src.rpm
keyutils-1.5.9-4.fc21.src.rpm
kmod-18-4.fc21.src.rpm
krb5-1.12.2-9.fc21.src.rpm
less-458-13.fc21.src.rpm
libarchive-3.1.2-10.fc21.src.rpm
libassuan-2.1.0-5.fc21.src.rpm
libcap-2.24-7.fc21.src.rpm
libcap-ng-0.7.4-7.fc21.src.rpm
libcgroup-0.41-6.fc21.src.rpm
libdb-5.3.28-9.fc21.src.rpm
libedit-3.1-8.20140213cvs.fc21.src.rpm
libffi-3.1-6.fc21.src.rpm
libgcrypt-1.6.1-7.fc21.src.rpm
libgpg-error-1.13-3.fc21.src.rpm
libidn-1.28-5.fc21.src.rpm
libmetalink-0.1.2-7.fc21.src.rpm
libmnl-1.0.3-9.fc21.src.rpm
libnetfilter_conntrack-1.0.4-4.fc21.src.rpm
libnfnetlink-1.0.1-6.fc21.src.rpm
libpipeline-1.3.0-4.fc21.src.rpm
libpwquality-1.2.4-2.fc21.src.rpm
libseccomp-2.1.1-5.fc21.src.rpm
libselinux-2.3-5.fc21.src.rpm
libsemanage-2.3-6.fc21.src.rpm
libsepol-2.3-4.fc21.src.rpm
libssh2-1.4.3-16.fc21.src.rpm
libtasn1-4.2-1.fc21.src.rpm
libuser-0.60-6.fc21.src.rpm
libutempter-1.1.6-6.fc21.src.rpm
libverto-0.2.6-4.fc21.src.rpm
libxml2-2.9.1-6.fc21.src.rpm
libyaml-0.1.6-5.fc21.src.rpm
linux-atm-2.5.1-11.fc21.src.rpm
lua-5.2.2-8.fc21.src.rpm
lvm2-2.02.111-1.fc21.src.rpm
lzo-2.08-3.fc21.src.rpm
man-db-2.6.7.1-12.fc21.src.rpm
mtools-4.0.18-7.fc21.src.rpm
ncurses-5.9-16.20140323.fc21.src.rpm
net-tools-2.0-0.28.20140707git.fc21.src.rpm
(none)
nspr-4.10.7-1.fc21.src.rpm
nss-3.17.2-1.fc21.src.rpm
nss-softokn-3.17.2-1.fc21.src.rpm
nss-util-3.17.2-1.fc21.src.rpm
openldap-2.4.40-2.fc21.src.rpm
openssh-6.6.1p1-8.fc21.src.rpm
openssl-1.0.1j-1.fc21.src.rpm
p11-kit-0.22.1-1.fc21.src.rpm
pam-1.1.8-16.fc21.src.rpm
parted-3.2-4.fc21.src.rpm
passwd-0.79-5.fc21.src.rpm
pcre-8.35-7.fc21.src.rpm
pinentry-0.8.3-7.fc21.src.rpm
pkgconfig-0.28-6.fc21.src.rpm
policycoreutils-2.3-7.1.fc21.src.rpm
popt-1.16-5.fc21.src.rpm
procps-ng-3.3.10-4.fc21.src.rpm
pth-2.0.7-25.fc21.src.rpm
pygpgme-0.3-12.fc21.src.rpm
pyliblzma-0.5.3-13.fc21.src.rpm
python-2.7.8-7.fc21.src.rpm
python-backports-1.0-5.fc21.src.rpm
python-backports-ssl_match_hostname-3.4.0.2-4.fc21.src.rpm
python-boto-2.34.0-4.fc21.src.rpm
python-chardet-2.2.1-2.fc21.src.rpm
python-cheetah-2.4.4-10.fc21.src.rpm
python-configobj-5.0.5-2.fc21.src.rpm
python-iniparse-0.4-15.fc21.src.rpm
python-IPy-0.81-12.fc21.src.rpm
python-jsonpatch-1.2-4.fc21.src.rpm
python-jsonpointer-1.0-6.fc21.src.rpm
python-prettytable-0.7.2-4.fc21.src.rpm
python-psutil-1.2.1-5.fc21.src.rpm
python-pycurl-7.19.3.1-5.fc21.src.rpm
python-requests-2.3.0-3.fc21.src.rpm
python-rsa-3.1.1-6.fc21.src.rpm
python-setuptools-2.0-8.fc21.src.rpm
python-six-1.7.3-2.fc21.src.rpm
python-urlgrabber-3.10.1-2.fc21.src.rpm
python-urllib3-1.8.2-4.fc21.src.rpm
pyxattr-0.5.3-4.fc21.src.rpm
PyYAML-3.11-6.fc21.src.rpm
qrencode-3.4.2-4.fc21.src.rpm
readline-6.3-5.fc21.src.rpm
rootfiles-8.1-17.fc21.src.rpm
rpm-4.12.0.1-3.fc21.src.rpm
rsync-3.1.1-3.fc21.src.rpm
ruby-2.1.4-24.fc21.src.rpm
rubygem-rdoc-4.1.1-2.fc21.src.rpm
rubygems-2.2.2-101.fc21.src.rpm
rubypick-1.1.1-2.fc21.src.rpm
sed-4.2.2-9.fc21.src.rpm
selinux-policy-3.13.1-99.fc21.src.rpm
setools-3.3.8-5.fc21.src.rpm
setup-2.9.0-2.fc21.src.rpm
shadow-utils-4.1.5.1-17.fc21.src.rpm
shared-mime-info-1.3-15.fc21.src.rpm
sqlite-3.8.7-1.fc21.src.rpm
sudo-1.8.8-7.fc21.src.rpm
syslinux-6.03-1.fc21.src.rpm
systemd-216-12.fc21.src.rpm
tar-1.27.1-7.fc21.src.rpm
tcp_wrappers-7.6-79.fc21.src.rpm
texinfo-5.2-5.fc21.src.rpm
tzdata-2014i-1.fc21.src.rpm
ustr-1.0.4-18.fc21.src.rpm
util-linux-2.25.2-1.fc21.src.rpm
vim-7.4.475-2.fc21.src.rpm
wget-1.15-3.fc21.src.rpm
xz-5.1.2-14alpha.fc21.src.rpm
yum-3.4.3-153.fc21.src.rpm
yum-metadata-parser-1.1.4-14.fc21.src.rpm
zlib-1.2.8-7.fc21.src.rpm

I am volunteering to update the specs as a proven packager.

Closing this ticket as part of trac clean up process. If you want to reopen, please reopen it after we move to pagure.io as atomic-wg.

Login to comment on this ticket.

Metadata