#6255 Clean out obsolete buildroot overrides
Closed: Fixed None Opened 4 years ago by kalev.

I've got a case where f23-override has an older override than what's in stable and is breaking builds of dependant packages:

{{{
$ koji latest-pkg f23-build libgit2-glib
Build Tag Built by


libgit2-glib-0.23.2-1.fc23 f23-override zbyszek

$ koji latest-pkg f23 libgit2-glib
Build Tag Built by


libgit2-glib-0.23.4-1.fc23 f23 zbyszek
}}}

This is probably because Bodhi 2 doesn't track overrides that were created by Bodhi 1 and the old overrides just stayed forever. Would be great to clean this up; in addition to the libgit2-glib build above, I ran a script and found a number of other obsolete overrides. It should be fine to untag all the following as they have all newer builds in stable now:

{{{
koji untag-build f23-override Field3D-1.6.1-7.fc23 MUMPS-5.0.1-2.fc23 OpenImageIO-1.5.18-2.fc23 Ray-2.3.1-11.fc23 boost-1.58.0-4.fc23 boost-1.58.0-6.fc23 cegui-0.8.4-11.fc23 ceph-0.94.2-4.fc23 console-bridge-0.2.7-6.fc23 device-mapper-persistent-data-0.5.5-1.fc23 dl_poly-1.9.20140324-14.fc23 dmlite-0.7.3-2.fc23 elk-3.1.12-14.fc23 elpa-2015.05.001-2.fc23 espresso-3.3.0-7.fc23 execstack-0.5.0-8.fc23 freefem++-3.31-7.3.fc23 ga-5.3b-18.fc23 gnuradio-3.7.8-0.2.rc1.fc23 gpaw-0.11.0.13004-15.fc23 gr-air-modes-0-0.37.20140312gitcc0fa180.fc23 gr-fcdproplus-0-0.14.20140920git1edbe523.fc23 gr-iqbal-0.37.2-11.fc23 gr-osmosdr-0.1.3-10.20141023git42c66fdd.fc23 gromacs-5.0.6-6.fc23 gstreamer1-1.5.90-1.fc23 gstreamer1-plugins-base-1.5.90-1.fc23 gstreamer1-plugins-good-1.5.90-1.fc23 hdf5-1.8.15-6.patch1.fc23 hpl-2.1-13.fc23 libgit2-glib-0.23.0-2.fc23 libgit2-glib-0.23.2-1.fc23 libzhuyin-1.0.91-1.fc23 mathgl-2.3-10.fc23 mingw-headers-4.0.4-3.fc23 mpi4py-1.3.1-12.fc23 mpi4py-1.3.1-13.fc23 mpi4py-1.3.1-14.fc23 mpich-3.1.4-5.fc23 netcdf-4.3.3.1-5.fc23 netgen-mesher-5.3.1-8.fc23 nodejs-single-line-log-1.0.0-1.fc23 ogre-1.9.0-12.fc23 openmpi-1.8.8-2.fc23 openmpi-1.8.8-3.fc23 orsa-0.7.0-33.fc23 pcl-1.7.2-8.fc23 player-3.0.2-45.fc23 pypar-2.1.5_108-10.fc23 pypar-2.1.5_108-11.fc23 rpm-mpi-hooks-3-1.fc23 rpm-mpi-hooks-3-2.fc23 scalapack-2.0.2-10.fc23 scorep-1.4.2-2.fc23 scotch-6.0.4-5.fc23 sdformat-2.3.2-6.fc23 source-highlight-3.1.8-4.fc23 source-highlight-qt-0.2.3-14.fc23 sundials-2.6.2-4.fc23 swig-3.0.7-2.fc23 uhd-3.8.2-8.fc23 urdfdom-0.3.0-10.fc23 valgrind-3.10.1-19.fc23
}}}

Thanks,
Kalev


Metadata Update from @kalev:
- Issue set to the milestone: Fedora 23 Beta

3 years ago

Login to comment on this ticket.

Metadata