#33669 New Repo for "rpms/ansible-collection-containers-podman"
Closed: Processed by humaton. Opened by sshnaidm.

{
 "action": "new_repo",
 "branch": "rawhide",
 "bug_id": 1927697,
 "description": "",
 "exception": false,
 "monitor": "monitoring",
 "namespace": "rpms",
 "repo": "ansible-collection-containers-podman",
 "summary": "Ansible collection for Podman containers",
 "upstreamurl": ""
}

The email address "panemade@gmail.com" of the Bugzilla reviewer is not tied to a user in FAS. Group membership can't be validated.

Metadata Update from @humaton:
- Issue close_status updated to: Invalid
- Issue status updated to: Closed (was: Open)

@humaton with the new FAS system I think problems started for existing Sponsors who are not having very straight setup. Before the new FAS system, I was able to use my inactive FAS id paragn tide to my gmail id. But I always sponsors using active FAS id pnemade.

May I know what got changed with new FAS system? Also if I have sponsored using correct FAS id why does BZ approver email ID matters here? I have seen in the past new contributor gets sponsored by some other person and reviewers was some other person.

Where is the new change implemented that prevents inactive FAS id from approving package reviews? is it in fedscm script ?

Before the new FAS system, I was able to use my inactive FAS id paragn tide to my gmail id. But I always sponsors using active FAS id pnemade.

Inactive accounts have not been migrated: https://lists.fedoraproject.org/archives/list/devel-announce@lists.fedoraproject.org/thread/SRYH5P7DXY3FE2VVCBNRI6VXN636LPK6/

Ok I understand that but what fix is needed here? Do I need to activate old FAS account? I want to keep using 2 bz accounts. One for package reviews and other my official RH work. I don't want this package owner be blocked for my own issue.

Please suggest some fix here.

@pingou I just tried forgot password for paragn and it failed redirecting to url https://accounts.fedoraproject.org/forgot-password/ask which said "The server encountered an internal error and was unable to complete your request. Either the server is overloaded or there is an error in the application."

@humaton I have activated my gmail id. Can this request be processed again or need to report again new fresh request?

@sshnaidm Can you try to open this ticket?

Metadata Update from @sshnaidm:
- Issue status updated to: Open (was: Closed)

The Bugzilla bug's review is submitted by a user that is not a packager

Metadata Update from @limb:
- Issue close_status updated to: Invalid
- Issue status updated to: Closed (was: Open)

I don't understand what is the problem - I'm a in "packager" group, you can see it here: https://accounts.fedoraproject.org/user/sshnaidm/

Metadata Update from @sshnaidm:
- Issue status updated to: Open (was: Closed)

The Bugzilla bug's review is submitted by a user that is not a packager

Metadata Update from @limb:
- Issue close_status updated to: Invalid
- Issue status updated to: Closed (was: Open)

@pnemade @limb sorry, do you know what is the current issue here? I can't understand what should be done to proceed with this.

@limb looks like script still goes to old FAS where sshnaidm is unapproved in packager group?

https://admin.fedoraproject.org/accounts/user/view/sshnaidm

I don't see sshnaidm in packager in the new accounts system, either.

Nm, there you are. @mohanboddu ?

FAS2 is deprecated. I logged in there and tried to sponsor @sshnaidm but as its read-only system it returned "500 Internal error".
@sshnaidm Can you please login once to https://accounts.fedoraproject.org/ after I have sponsored you in packager group? Also see if you can login to https://src.fedoraproject.org

I found this relevant issue https://pagure.io/releng/issue/10080

I think issue here is from fedora-infra team who deployed new FAS system without understanding its limitations.

@humaton @limb Please don't close this issue. If it gets closed automatically keep it open. We need to find some fix here. Its really new FAS system issue not about package reporter or reviewer issue.

Metadata Update from @sshnaidm:
- Issue status updated to: Open (was: Closed)

As I see there are a lot of issues closed because of this reason. This definitely requires a solution.

The Bugzilla bug's review is submitted by a user that is not a packager

Metadata Update from @limb:
- Issue close_status updated to: Invalid
- Issue status updated to: Closed (was: Open)

Metadata Update from @humaton:
- Issue status updated to: Open (was: Closed)

Hi @pnemade , I am unable to find the reviewer email in fasjson https://fasjson.fedoraproject.org/v1/search/users/?email=panemade@gmail.com.

That is basically the query that is done by fedscm_admin to determine user groups. Even when the new fedscm_admin tool is released this will not change.

Metadata Update from @humaton:
- Issue close_status updated to: Invalid
- Issue status updated to: Closed (was: Open)

@humaton What does that mean? Can you help what actions I need to fix it?

@pnemade so your BZ email is not associated with any fas account. If you could add the gmail to your fas the ticket should be processed.

If you have any troubles ping me on freenode, jednorozec at fedora-releng

Metadata Update from @humaton:
- Issue status updated to: Open (was: Closed)

@sshnaidm needs to login to https://src.fedoraproject.org to sync accounts before we can proceed.

@humaton I logged in there.

The Pagure repository was created at https://src.fedoraproject.org/rpms/ansible-collection-containers-podman

Metadata Update from @humaton:
- Issue close_status updated to: Processed
- Issue status updated to: Closed (was: Open)

@sshnaidm I am glad finally repository has been created here. It turns out new FAS issues but its all fixed now so we are good now :)

@pnemade @humaton great, thanks for you help!

Metadata