#8253 Postgresql not available in the communishift.
Opened 2 months ago by cverna. Modified 4 days ago

Postgresql is not available in the communishift catalog this makes it not easy to deploy a database.


Metadata Update from @bowlofeggs:
- Issue priority set to: Waiting on Assignee (was: Needs Review)

2 months ago

Metadata Update from @cverna:
- Issue tagged with: backlog

2 months ago

So yeah, openshift4 doesn't have as many things in the developer catalog, because they want to use operators. ;)

Can you look and see if you can see:

Catalog->operator hub-> search for postgresql

There should be 2 operators there... crunchy seems to take a fair bit of setup, but dev4devs one can install on one namespace. Can you see if it will let you install it on your app/namespace?

I can't look at the Catalog:

clusterserviceversions.operators.coreos.com is forbidden: User "bcotton" cannot list resource "clusterserviceversions" in API group "operators.coreos.com" in the namespace "bcotton-test"

from Catalog -> Developer Catalog. There is no "Operator Hub" section visible under Catalog.

So, I think this is now fixed, can you please login and confirm you can add a postgresql template from the developer catalog?

@bcotton Could you check this is fixed?

I can't log in, so I can't say one way or another.

I still get:

Please enter the master password for the PIV_II

when I try to log in to https://console-openshift-console.apps.os.fedorainfracloud.org/

@bcotton Are you sure you are choosing the fedora idp not the kubectl auth?

@bcotton Are you sure you are choosing the fedora idp not the kubectl auth?

Ah! I didn't realize when I got punted to that screen that it was a selectable option. (I didn't get that screen until after the "master password" error). I can, in fact, log in now that I know where to look.

And I do see Postgres in the catalog, so this can be closed. Thanks!

Login to comment on this ticket.

Metadata