#30 Broken EPEL 6 buildroot
Closed: Fixed None Opened 4 years ago by ellert.

The installation of the buildroot for EPEL 6 fails.

https://kojipkgs.fedoraproject.org//work/tasks/6262/8686262/root.log

{{{
DEBUG util.py:366: http://kojipkgs.fedoraproject.org/repo/rhel/rhel-x86_64-server-6/getPackage/openssl-1.0.1e-30.el6_6.4.x86_64.rpm: [Errno 14] HTTP Error 404 - Not Found
DEBUG util.py:366: Trying other mirror.
DEBUG util.py:366: Error downloading packages:
DEBUG util.py:366: openssl-1.0.1e-30.el6_6.4.x86_64: failed to retrieve openssl-1.0.1e-30.el6_6.4.x86_64.rpm from build
DEBUG util.py:366: error was [Errno 14] HTTP Error 404 - Not Found
DEBUG util.py:476: Child return code was: 1
}}}


This was fixed by someone. The build now tries to install openssl.x86_64 0:1.0.1e-30.el6_6.5 instead - which succeeds.

just FYI, 99% of the time this corrects itself.

What happens is:

new errata package is released for rhel.
We sync that new package and the old one disappears.
koji runs a newrepo and picks up the new package and all is well.

It's only in that window between a package disappearing and the next newrepo you would get this. ;(

How often is a newrepo run triggered?

I now again have a broken repo for an EPEL6 build:

Error downloading packages:
jasper-libs-1.900.1-16.el6_6.2.x86_64: failed to retrieve jasper-libs-1.900.1-16.el6_6.2.x86_64.rpm from build

Interestingly the i686 build works - but installs a different version:

Dependency Installed:
jasper-libs.i686 0:1.900.1-16.el6_6.3

There hasn't been a run of "newRepo (dist-6E-epel-build)" since 2015-01-27 18:59:49 UTC which is 13 hours ago. Am I just unlucky?

https://koji.fedoraproject.org/koji/taskinfo?taskID=8742219

https://koji.fedoraproject.org/koji/taskinfo?taskID=8751139

Should be ok now?

koji only runs 3 newrepos at once, and right now with all the side tags it takes a while to get caught up.

Login to comment on this ticket.

Metadata