#9 Fedora-Rawhide-20180220.n.0 FINISHED_INCOMPLETE
Opened 2 years ago by dustymabe. Modified 2 years ago

pungi.global.log

  • No Task ID, look at log statement
[OSTREE_INSTALLER] [INFO    ] [FAIL] Ostree installer (variant WorkstationOstree, arch x86_64) failed, but going on anyway.
[OSTREE_INSTALLER] [INFO    ] ('Could not create volume ID longer than 32 bytes, options are %r', ['Fedora-WSOstree-ostree-x86_64-rawh'])
[IMAGE_BUILD     ] [INFO    ] [FAIL] Image build (variant Container, arch *, subvariant Container_Base) failed, but going on anyway.
[IMAGE_BUILD     ] [INFO    ] ImageBuild task failed: 25182891. See /mnt/koji/compose/rawhide/Fedora-Rawhide-20180220.n.0/logs/aarch64-armhfp-ppc64le-x86_64/imagebuild-Container-Container_Base-docker.aarch64-armhfp-ppc64le-x86_64.log for more details.
[LIVE_MEDIA      ] [INFO    ] [FAIL] Live media (variant Labs, arch *, subvariant Astronomy_KDE) failed, but going on anyway.
[LIVE_MEDIA      ] [INFO    ] Live media task failed: 25182871. See /mnt/koji/compose/rawhide/Fedora-Rawhide-20180220.n.0/logs/i386-x86_64/livemedia-Labs-Astronomy_KDE.i386-x86_64.log for more details.
[LIVE_MEDIA      ] [INFO    ] [FAIL] Live media (variant Labs, arch *, subvariant Games) failed, but going on anyway.
[LIVE_MEDIA      ] [INFO    ] Live media task failed: 25182895. See /mnt/koji/compose/rawhide/Fedora-Rawhide-20180220.n.0/logs/i386-x86_64/livemedia-Labs-Games.i386-x86_64.log for more details.
[LIVE_MEDIA      ] [INFO    ] [FAIL] Live media (variant Labs, arch *, subvariant Scientific_KDE) failed, but going on anyway.
[LIVE_MEDIA      ] [INFO    ] Live media task failed: 25182884. See /mnt/koji/compose/rawhide/Fedora-Rawhide-20180220.n.0/logs/i386-x86_64/livemedia-Labs-Scientific_KDE.i386-x86_64.log for more details.
[LIVE_MEDIA      ] [INFO    ] [FAIL] Live media (variant Labs, arch *, subvariant Robotics) failed, but going on anyway.
[LIVE_MEDIA      ] [INFO    ] Live media task failed: 25182917. See /mnt/koji/compose/rawhide/Fedora-Rawhide-20180220.n.0/logs/i386-x86_64/livemedia-Labs-Robotics.i386-x86_64.log for more details.
[LIVE_MEDIA      ] [INFO    ] [FAIL] Live media (variant Labs, arch *, subvariant Security) failed, but going on anyway.
[LIVE_MEDIA      ] [INFO    ] Live media task failed: 25182907. See /mnt/koji/compose/rawhide/Fedora-Rawhide-20180220.n.0/logs/i386-x86_64/livemedia-Labs-Security.i386-x86_64.log for more details.
[LIVE_MEDIA      ] [INFO    ] [FAIL] Live media (variant Labs, arch *, subvariant Python_Classroom) failed, but going on anyway.
[LIVE_MEDIA      ] [INFO    ] Live media task failed: 25182929. See /mnt/koji/compose/rawhide/Fedora-Rawhide-20180220.n.0/logs/i386-x86_64/livemedia-Labs-Python_Classroom.i386-x86_64.log for more details.
[LIVE_MEDIA      ] [INFO    ] [FAIL] Live media (variant Labs, arch *, subvariant Jam_KDE) failed, but going on anyway.
[LIVE_MEDIA      ] [INFO    ] Live media task failed: 25182914. See /mnt/koji/compose/rawhide/Fedora-Rawhide-20180220.n.0/logs/i386-x86_64/livemedia-Labs-Jam_KDE.i386-x86_64.log for more details.
[LIVE_IMAGES     ] [INFO    ] [FAIL] Live (variant Labs, arch armhfp, subvariant Python_Classroom) failed, but going on anyway.
[LIVE_IMAGES     ] [INFO    ] LiveImage task failed: 25182916. See /mnt/koji/compose/rawhide/Fedora-Rawhide-20180220.n.0/logs/armhfp/liveimage-Fedora-Python-Classroom-armhfp-Rawhide-20180220.n.0.armhfp.log for more details.
[LIVE_IMAGES     ] [INFO    ] [FAIL] Live (variant Workstation, arch armhfp, subvariant Workstation) failed, but going on anyway.
[LIVE_IMAGES     ] [INFO    ] LiveImage task failed: 25182851. See /mnt/koji/compose/rawhide/Fedora-Rawhide-20180220.n.0/logs/armhfp/liveimage-Fedora-Workstation-armhfp-Rawhide-20180220.n.0.armhfp.log for more details.
[LIVE_IMAGES     ] [INFO    ] [FAIL] Live (variant Spins, arch armhfp, subvariant LXDE) failed, but going on anyway.
[LIVE_IMAGES     ] [INFO    ] LiveImage task failed: 25182858. See /mnt/koji/compose/rawhide/Fedora-Rawhide-20180220.n.0/logs/armhfp/liveimage-Fedora-LXDE-armhfp-Rawhide-20180220.n.0.armhfp.log for more details.
[LIVE_IMAGES     ] [INFO    ] [FAIL] Live (variant Spins, arch armhfp, subvariant Mate) failed, but going on anyway.
[LIVE_IMAGES     ] [INFO    ] LiveImage task failed: 25182869. See /mnt/koji/compose/rawhide/Fedora-Rawhide-20180220.n.0/logs/armhfp/liveimage-Fedora-Mate-armhfp-Rawhide-20180220.n.0.armhfp.log for more details.
[LIVE_IMAGES     ] [INFO    ] [FAIL] Live (variant Spins, arch armhfp, subvariant LXQt) failed, but going on anyway.
[LIVE_IMAGES     ] [INFO    ] LiveImage task failed: 25182901. See /mnt/koji/compose/rawhide/Fedora-Rawhide-20180220.n.0/logs/armhfp/liveimage-Fedora-LXQt-armhfp-Rawhide-20180220.n.0.armhfp.log for more details.
[LIVE_IMAGES     ] [INFO    ] [FAIL] Live (variant Spins, arch armhfp, subvariant KDE) failed, but going on anyway.
[LIVE_IMAGES     ] [INFO    ] LiveImage task failed: 25182854. See /mnt/koji/compose/rawhide/Fedora-Rawhide-20180220.n.0/logs/armhfp/liveimage-Fedora-KDE-armhfp-Rawhide-20180220.n.0.armhfp.log for more details.

[OSTREE_INSTALLER] [INFO    ] [FAIL] Ostree installer (variant WorkstationOstree, arch x86_64) failed, but going on anyway.
[OSTREE_INSTALLER] [INFO    ] ('Could not create volume ID longer than 32 bytes, options are %r', ['Fedora-WSOstree-ostree-x86_64-rawh'])

possible temporary workaround in https://pagure.io/pungi-fedora/pull-request/525#

the volid issue should be temporarily worked around by this pungi-fedora PR. The container imagebuild issue should be fixed now as dgilmore forgot to add the package when he merged the pungi changes. This was needed because of this koji-sync-listener.py issue.

Ok I finally took a look at the Live* failures. Here is a summary:

25182916 Python_Classroom Lab armhfp

DEBUG util.py:439:   Problem: package webkit2gtk3-2.19.6-2.fc28.armv7hl requires libenchant.so.1, but none of the providers can be installed
DEBUG util.py:439:    - package emacs-1:25.3-5.fc28.armv7hl requires libwebkit2gtk-4.0.so.37, but none of the providers can be installed
DEBUG util.py:439:    - package enchant-1:1.6.0-20.fc28.armv7hl requires libhunspell-1.6.so.0, but none of the providers can be installed
DEBUG util.py:439:    - conflicting requests
DEBUG util.py:439:    - nothing provides hunspell-en-US needed by hunspell-1.6.2-1.fc28.armv7hl

25182914 Labs, arch *, Jam_KDE

DEBUG util.py:439:  2018-02-20 11:49:44,772: Problem: conflicting requests
DEBUG util.py:439:  2018-02-20 11:49:44,772: - nothing provides libm17n-core.so.0()(64bit) needed by emacs-1:25.3-5.fc28.x86_64.

25182907 Labs, arch *, Security

DEBUG util.py:439:  2018-02-20 11:49:11,866: Problem: conflicting requests
DEBUG util.py:439:  2018-02-20 11:49:11,866: - package anaconda-28.22-1.fc28.x86_64 requires anaconda-core = 28.22-1.fc28, but none of the providers can be installed
DEBUG util.py:439:  2018-02-20 11:49:11,866: - nothing provides realmd needed by anaconda-core-28.22-1.fc28.x86_64.

25182917 Labs, arch *, subvariant Robotics

DEBUG util.py:439:  2018-02-20 11:49:29,104: Non interactive installation failed:
DEBUG util.py:439:  2018-02-20 11:49:29,104: Problem 1: conflicting requests
DEBUG util.py:439:  2018-02-20 11:49:29,104: - nothing provides pkgconfig(pcl_2d-1.8) needed by pcl-devel-1.8.1-1.fc28.i686
DEBUG util.py:439:  2018-02-20 11:49:29,104: - nothing provides pkgconfig(pcl_2d-1.8) needed by pcl-devel-1.8.1-1.fc28.x86_64
DEBUG util.py:439:  2018-02-20 11:49:29,104: Problem 2: conflicting requests
DEBUG util.py:439:  2018-02-20 11:49:29,105: - package player-devel-3.1.0-4.fc27.i686 requires liblodo.so.3.1, but none of the providers can be installed
DEBUG util.py:439:  2018-02-20 11:49:29,105: - package player-devel-3.1.0-4.fc27.x86_64 requires libplayercommon.so.3.1()(64bit), but none of the providers can be installed
DEBUG util.py:439:  2018-02-20 11:49:29,105: - nothing provides libboost_system.so.1.64.0 needed by player-3.1.0-4.fc27.i686
DEBUG util.py:439:  2018-02-20 11:49:29,105: - nothing provides libboost_system.so.1.64.0()(64bit) needed by player-3.1.0-4.fc27.x86_64
DEBUG util.py:439:  2018-02-20 11:49:29,105: Problem 3: conflicting requests
DEBUG util.py:439:  2018-02-20 11:49:29,105: - package mrpt-devel-1.4.0-6.fc28.i686 requires libmrpt-detectors.so.1.4, but none of the providers can be installed
DEBUG util.py:439:  2018-02-20 11:49:29,105: - package mrpt-devel-1.4.0-6.fc28.x86_64 requires libmrpt-gui.so.1.4()(64bit), but none of the providers can be installed
DEBUG util.py:439:  2018-02-20 11:49:29,106: - nothing provides libboost_system.so.1.64.0 needed by mrpt-libs-1.4.0-6.fc28.i686
DEBUG util.py:439:  2018-02-20 11:49:29,106: - nothing provides libboost_system.so.1.64.0()(64bit) needed by mrpt-libs-1.4.0-6.fc28.x86_64
DEBUG util.py:439:  2018-02-20 11:49:29,106: Problem 4: conflicting requests
DEBUG util.py:439:  2018-02-20 11:49:29,106: - package firefox-58.0.2-1.fc28.x86_64 requires libhunspell-1.6.so.0()(64bit), but none of the providers can be installed
DEBUG util.py:439:  2018-02-20 11:49:29,106: - nothing provides hunspell-en-US needed by hunspell-1.6.2-1.fc28.x86_64
DEBUG util.py:439:  2018-02-20 11:49:29,106: Problem 5: conflicting requests
DEBUG util.py:439:  2018-02-20 11:49:29,107: - package anaconda-28.22-1.fc28.x86_64 requires anaconda-gui = 28.22-1.fc28, but none of the providers can be installed
DEBUG util.py:439:  2018-02-20 11:49:29,107: - package anaconda-gui-28.22-1.fc28.x86_64 requires yelp, but none of the providers can be installed
DEBUG util.py:439:  2018-02-20 11:49:29,107: - package yelp-2:3.27.1-3.fc28.x86_64 requires libwebkit2gtk-4.0.so.37()(64bit), but none of the providers can be installed
DEBUG util.py:439:  2018-02-20 11:49:29,107: - package webkit2gtk3-2.19.6-2.fc28.x86_64 requires libenchant.so.1()(64bit), but none of the providers can be installed
DEBUG util.py:439:  2018-02-20 11:49:29,107: - package enchant-1:1.6.0-20.fc28.x86_64 requires libhunspell-1.6.so.0()(64bit), but none of the providers can be installed
DEBUG util.py:439:  2018-02-20 11:49:29,107: - nothing provides hunspell-en-US needed by hunspell-1.6.2-1.fc28.x86_64.

25182851 Workstation armhfp live image

DEBUG util.py:439:     At least 93MB more space needed on the / filesystem.

25182858 Spins armhfp LXDE

DEBUG util.py:439:     At least 926MB more space needed on the / filesystem.

25182869 Spins armhfp Mate

DEBUG util.py:439:     At least 121MB more space needed on the / filesystem.

25182901 Spins armhfp LXQt

DEBUG util.py:439:     At least 180MB more space needed on the / filesystem.

25182854 Spins armhfp KDE

DEBUG util.py:439:     At least 294MB more space needed on the / filesystem.

ok for the dependency issues most of them should get taken care of by https://pagure.io/fedora-kickstarts/pull-request/338

I haven't figured out how to adjust the disk size for the appliance images yet. Will work on that tomorrow.

There are some genuine dependency issues left (as seen in 25182917 Robotics Lab. Looks like some stuff needs to be rebuilt:

 Problem 1: conflicting requests
  - nothing provides pkgconfig(pcl_2d-1.8) needed by pcl-devel-1.8.1-1.fc28.i686
  - nothing provides pkgconfig(pcl_2d-1.8) needed by pcl-devel-1.8.1-1.fc28.x86_64
 Problem 2: conflicting requests
  - package player-devel-3.1.0-4.fc27.i686 requires liblodo.so.3.1, but none of the providers can be installed
  - package player-devel-3.1.0-4.fc27.x86_64 requires libplayercommon.so.3.1()(64bit), but none of the providers can be installed
  - nothing provides libboost_system.so.1.64.0 needed by player-3.1.0-4.fc27.i686
  - nothing provides libboost_system.so.1.64.0()(64bit) needed by player-3.1.0-4.fc27.x86_64
 Problem 3: conflicting requests
  - package mrpt-devel-1.4.0-6.fc28.i686 requires libmrpt-detectors.so.1.4, but none of the providers can be installed
  - package mrpt-devel-1.4.0-6.fc28.x86_64 requires libmrpt-gui.so.1.4()(64bit), but none of the providers can be installed
  - nothing provides libboost_system.so.1.64.0 needed by mrpt-libs-1.4.0-6.fc28.i686
  - nothing provides libboost_system.so.1.64.0()(64bit) needed by mrpt-libs-1.4.0-6.fc28.x86_64

All of the dep issues have been filed against the components: pcl, mrpt, player.

Login to comment on this ticket.

Metadata