#24 Fedora-Rawhide-20180227.n.0 DOOMED
Opened 8 months ago by dustymabe. Modified 8 months ago

pungi.global.log

[INFO    ] [FAIL] Ostree (variant ostree, arch x86_64) failed, but going on anyway.
[INFO    ] Runroot task failed: 25342869. See /mnt/koji/compose/rawhide/Fedora-Rawhide-20180227.n.0/logs/x86_64/ostree/ostree-4/runroot.log for more details.
[LIVE_MEDIA      ] [INFO    ] [FAIL] Live media (variant Labs, arch *, subvariant Astronomy_KDE) failed, but going on anyway.
[LIVE_MEDIA      ] [INFO    ] Live media task failed: 25343802. See /mnt/koji/compose/rawhide/Fedora-Rawhide-20180227.n.0/logs/i386-x86_64/livemedia-Labs-Astronomy_KDE.i386-x86_64.log for more details.
[LIVE_MEDIA      ] [INFO    ] [FAIL] Live media (variant Labs, arch *, subvariant Scientific_KDE) failed, but going on anyway.
[LIVE_MEDIA      ] [INFO    ] Live media task failed: 25343818. See /mnt/koji/compose/rawhide/Fedora-Rawhide-20180227.n.0/logs/i386-x86_64/livemedia-Labs-Scientific_KDE.i386-x86_64.log for more details.
[LIVE_MEDIA      ] [INFO    ] [FAIL] Live media (variant Labs, arch *, subvariant Robotics) failed, but going on anyway.
[LIVE_MEDIA      ] [INFO    ] Live media task failed: 25343850. See /mnt/koji/compose/rawhide/Fedora-Rawhide-20180227.n.0/logs/i386-x86_64/livemedia-Labs-Robotics.i386-x86_64.log for more details.
[LIVE_IMAGES     ] [INFO    ] [FAIL] Live (variant Workstation, arch armhfp, subvariant Workstation) failed, but going on anyway.
[LIVE_IMAGES     ] [INFO    ] LiveImage task failed: 25343852. See /mnt/koji/compose/rawhide/Fedora-Rawhide-20180227.n.0/logs/armhfp/liveimage-Fedora-Workstation-armhfp-Rawhide-20180227.n.0.armhfp.log for more details.
[LIVE_MEDIA      ] [INFO    ] [FAIL] Live media (variant Spins, arch *, subvariant Mate) failed, but going on anyway.
[LIVE_MEDIA      ] [INFO    ] Live media task failed: 25343873. See /mnt/koji/compose/rawhide/Fedora-Rawhide-20180227.n.0/logs/i386-x86_64/livemedia-Spins-Mate.i386-x86_64.log for more details.
[LIVE_MEDIA      ] [INFO    ] [FAIL] Live media (variant Spins, arch *, subvariant LXQt) failed, but going on anyway.
[LIVE_MEDIA      ] [INFO    ] Live media task failed: 25343874. See /mnt/koji/compose/rawhide/Fedora-Rawhide-20180227.n.0/logs/i386-x86_64/livemedia-Spins-LXQt.i386-x86_64.log for more details.
[IMAGE_BUILD     ] [INFO    ] [FAIL] Image build (variant Workstation, arch *, subvariant Workstation) failed, but going on anyway.
[IMAGE_BUILD     ] [INFO    ] ImageBuild task failed: 25343860. See /mnt/koji/compose/rawhide/Fedora-Rawhide-20180227.n.0/logs/aarch64/imagebuild-Workstation-Workstation-raw-xz.aarch64.log for more details.
  • Compose run failed because:
[ERROR   ] Compose run failed: Live media task failed: 25343875. See /mnt/koji/compose/rawhide/Fedora-Rawhide-20180227.n.0/logs/i386-x86_64/livemedia-Workstation-Workstation.i386-x86_64.log for more details.

i'm investigated all of these issues. standby for overview

  • 25342869 atomic workstation ostree compose

will be fixed by this PR, which removes fedora-productimg-workstation from the list of packages.

DEBUG util.py:439:  2018-02-27 12:06:38,291: - package plasma-applet-redshift-control-1.0.18-4.fc28.noarch requires plasma-desktop, but none of the providers can be installed
DEBUG util.py:439:  2018-02-27 12:06:38,291: - nothing provides libibus-1.0.so.5 needed by plasma-desktop-5.12.2-1.fc29.i686
DEBUG util.py:439:  2018-02-27 12:06:38,291: - nothing provides libibus-1.0.so.5()(64bit) needed by plasma-desktop-5.12.2-1.fc29.x86_64.

PR here to not exclude ibus. The next error I get after that for this package set is - nothing provides libqpdf.so.18()(64bit) needed by cups-filters-1.20.0-6.fc28.x86_64 so maybe cups-filters needs to be rebuilt?

DEBUG util.py:439:  2018-02-27 12:07:26,088: Non interactive installation failed:
DEBUG util.py:439:  2018-02-27 12:07:26,088: Problem 1: conflicting requests
DEBUG util.py:439:  2018-02-27 12:07:26,088: - nothing provides libgfortran.so.4()(64bit) needed by rkward-0.6.5-12.fc28.x86_64
DEBUG util.py:439:  2018-02-27 12:07:26,088: Problem 2: conflicting requests
DEBUG util.py:439:  2018-02-27 12:07:26,088: - nothing provides libjvm.so needed by scilab-6.0.0-1.fc26.i686
DEBUG util.py:439:  2018-02-27 12:07:26,088: - nothing provides libgfortran.so.4()(64bit) needed by scilab-6.0.0-1.fc26.x86_64
DEBUG util.py:439:  2018-02-27 12:07:26,089: Problem 3: conflicting requests
DEBUG util.py:439:  2018-02-27 12:07:26,089: - package scilab-devel-6.0.0-1.fc26.i686 requires scilab(x86-32) = 6.0.0-1.fc26, but none of the providers can be installed
DEBUG util.py:439:  2018-02-27 12:07:26,089: - package scilab-devel-6.0.0-1.fc26.x86_64 requires scilab(x86-64) = 6.0.0-1.fc26, but none of the providers can be installed
DEBUG util.py:439:  2018-02-27 12:07:26,089: - nothing provides libjvm.so needed by scilab-6.0.0-1.fc26.i686
DEBUG util.py:439:  2018-02-27 12:07:26,089: - nothing provides libgfortran.so.4()(64bit) needed by scilab-6.0.0-1.fc26.x86_64
DEBUG util.py:439:  2018-02-27 12:07:26,089: Problem 4: conflicting requests
DEBUG util.py:439:  2018-02-27 12:07:26,089: - package scilab-doc-6.0.0-1.fc26.noarch requires scilab = 6.0.0-1.fc26, but none of the providers can be installed
DEBUG util.py:439:  2018-02-27 12:07:26,090: - nothing provides libjvm.so needed by scilab-6.0.0-1.fc26.i686
DEBUG util.py:439:  2018-02-27 12:07:26,090: - nothing provides libgfortran.so.4()(64bit) needed by scilab-6.0.0-1.fc26.x86_64.

scliab was just rebuilt so maybe that will be fixed
looks like we need to try to rebuild rkward

all failed with losetup error:

DEBUG util.py:439:  subprocess.CalledProcessError: Command '['losetup', '--find', '--show', '/thebuilddir/tmp/lmc/lmc-disk-yfdl91yg.img']' returned non-zero exit status 1.
 DEBUG util.py:439:  Unable to create appliance : Failed to find package 'fedora-productimg-workstation' : no package matched: fedora-productimg-workstation

This PR should fix it for both.

action items from above:

  • 1 - review PRs: 1 2
  • 2 - investigate losetup issues
  • 3 - cups-filters needs to be rebuilt?
  • 4 - looks like we need to try to rebuild rkward?

We already started talking about the losetup problem in https://pagure.io/dusty/failed-composes/issue/15 . This is the kind of splitting of discussions I was afraid might happen, if we just keep filing new tickets for the same failure in different composes :/

We already started talking about the losetup problem in https://pagure.io/dusty/failed-composes/issue/15 . This is the kind of splitting of discussions I was afraid might happen, if we just keep filing new tickets for the same failure in different composes :/

solution to that would be to move it to a releng ticket and link to that similar to what I did in https://pagure.io/releng/issue/7326

qpdf looks like it got an unannounced soname bump.

so can we rebuild cups-filters ?

done already.

Thanks - action items left:

  • 1 - review PRs: 2
  • 2 - investigate losetup issues
  • 3 - cups-filters needs to be rebuilt?
  • 4 - looks like we need to try to rebuild rkward?

Re 4, there are a huge pile of broken R dependencies in current Rawhide. I suspect it'd be best to talk to a domain expert before attempting specific rebuilds.

Re 4, there are a huge pile of broken R dependencies in current Rawhide. I suspect it'd be best to talk to a domain expert before attempting specific rebuilds.

@spot was the one who was building them before. maybe he can help

rkward should just depend on R.

Also, all of the R build failures should have been due to the overzealous removal of the executable permission on the R "INSTALL" script, which is now fixed in f28+. I'd bet if they were all rebuilt again, most/all would succeed.

@spot so basically it should be OK to just fire a rebuild of rkward? If so, I'll do it.

I think so, though, I will admit that I have not looked at this specific rkward build fail. If it fails again, and you want me to look at it, lemme know.

I've rebuild rkward for Rawhide successfully, f28 build on the way now.

  • 1 - review PRs: 2
  • 2 - investigate losetup issues
  • 3 - cups-filters needs to be rebuilt?
  • 4 - looks like we need to try to rebuild rkward?

@adamwill - I took a closer look at the error message for the losetup issue and I don't think it's the same issue from the other day.

Today:

subprocess.CalledProcessError: Command '['losetup', '--find', '--show', '/thebuilddir/tmp/lmc/lmc-disk-yfdl91yg.img']' returned non-zero exit status 1.

The other day:

imgcreate.errors.MountError: Failed to unmap partitions for '/dev/loop0'

arm losetup issue was during disconnecting the loopback device and its seems today's issue is while actually initializing it.

I am not exactly sure why/how its happening.

Good spot, @dustymabe - as I hadn't heard anyone had done anything about the unmount error we were having on Friday I just assumed that was still there. But in fact it seems to have mysteriously gone away again. Odd.

The good news is, the remaining failures aren't in blocking images. I actually think we have all blocking failures addressed now, with the productimg PR merged, so we should fire another compose.

I think @puiterwijk was commenting the other day about something similar to this happening possibly because there are many tasks assigned to a single builder at a time and that builder running out of loopback devices. @puiterwijk, can you test that theory on today's data set?

Waitaminute, as @kevin also noticed, the losetup failure variant here is ultimately what broke the compose, too, as it affected the Workstation x86_64 live ISO task, #25343875.

I opened a ticket so we can track down the losetup issues over there: https://pagure.io/releng/issue/7355

Login to comment on this ticket.

Metadata