#348 Fix SafeConfigParser deprecation warning in cli
Merged a year ago by lholecek. Opened a year ago by lholecek.
lholecek/waiverdb fix-deprecation-warning  into  master

file modified
+1 -1
@@ -153,7 +153,7 @@ 

          waiverdb-cli -t dist.rpmdeplint -i qclib-1.3.1-3.fc28 -T koji_build \\

              -p "fedora-28" -c "This is expected for non-x86 packages"

      """

-     config = configparser.SafeConfigParser()

+     config = configparser.ConfigParser()

  

      config.read(config_file)

      validate_config(config)

Replace SafeConfigParser with ConfigParser as suggested by the warning.

waiverdb/cli.py:187: DeprecationWarning: The SafeConfigParser class
has been renamed to ConfigParser in Python 3.2. This alias will be
removed in future versions. Use ConfigParser directly instead.

Signed-off-by: Lukas Holecek hluk@email.cz

Pull-Request has been merged by lholecek

a year ago