455c9a2 Disable deprecation warnings for gtk_window_fullscreen_on_monitor

Authored and Committed by berrange 3 years ago
    Disable deprecation warnings for gtk_window_fullscreen_on_monitor
    
    We use GLIB_VERSION_MAX_ALLOWED to prevent use of functions from
    GTK >= 3.12. When we do conditional compilation based on a GTK
    version check, we must thus suppress the warning:
    
      CC       libvirt_viewer_la-virt-viewer-window.lo
    ../../src/virt-viewer-window.c: In function 'virt_viewer_window_enter_fullscreen':
    ../../src/virt-viewer-window.c:608:9: error: 'gtk_window_fullscreen_on_monitor' is deprecated: Not available before 3.18 [-Werror=deprecated-declarations]
             gtk_window_fullscreen_on_monitor(GTK_WINDOW(priv->window),
             ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    In file included from /usr/include/gtk-3.0/gtk/gtkdialog.h:32,
                     from /usr/include/gtk-3.0/gtk/gtkaboutdialog.h:30,
                     from /usr/include/gtk-3.0/gtk/gtk.h:31,
                     from ../../src/virt-viewer-window.c:28:
    /usr/include/gtk-3.0/gtk/gtkwindow.h:391:10: note: declared here
     void     gtk_window_fullscreen_on_monitor(GtkWindow *window,
              ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    cc1: all warnings being treated as errors
    
    Signed-off-by: Daniel P. Berrangé <berrange@redhat.com>
    
        
file modified
+3 -0