#78 Cannot start Silverblue 31 after upgrade
Closed a year ago by fedelibre. Opened a year ago by fedelibre.

I've upgraded to Silverblue 31 but the start up hangs on black screen as soon as the Fedora logo appears at the bottom.
I've pasted the journal logs of that boot here.

The most suspicious lines may be:

dic 12 10:07:46 localhost.localdomain systemd[859]: upower.service: Failed to set up special execution directory in /var/lib: Permission denied
dic 12 10:07:46 localhost.localdomain audit[859]: AVC avc:  denied  { read } for  pid=859 comm="(upowerd)" name="upower" dev="dm-0" ino=7864696 scontext=system_u:system_r:init_t:s0 tcontext=system_u:object_r:devicekit_var_lib_t:s0 tclass=dir permissive=0
dic 12 10:07:46 localhost.localdomain systemd[859]: upower.service: Failed at step STATE_DIRECTORY spawning /usr/libexec/upowerd: Permission denied

and in particular:

dic 12 10:07:46 localhost.localdomain systemd[899]: systemd-logind.service: Failed to set up special execution directory in /var/lib: Permission denied
dic 12 10:07:46 localhost.localdomain systemd[899]: systemd-logind.service: Failed at step STATE_DIRECTORY spawning /sbin/modprobe: Permission denied
-- Subject: Il processo /sbin/modprobe non può essere eseguito

which may be bug 1734831.

IIUC upgrading selinux-policy to 3.14.4 should fix the problem.

On Silverblue 30 I have:

$ rpm -q selinux-policy
selinux-policy-3.14.3-46.fc30.noarch

Just found the correct bug.

I'm closing this issue and follow up there.

Metadata Update from @fedelibre:
- Issue status updated to: Closed (was: Open)

a year ago

Login to comment on this ticket.

Metadata