#136 adjust libtaskotron terminology - formula, actions
Closed: Fixed None Opened 9 years ago by kparal.

Recipe

In D130 I wrote:

I use some new terminology in my patch, mainly I use "task recipe" instead of·
"task yaml file". I hit this problem when trying to reasonably name Context variables·
and our current terminology seemed a bit unclear to me. There might be a multiple
yaml files in the directory in the future, and then we will be confused. I think
it's helpful to use some analogies as other projects do, so that's why I started
calling "taskyaml file" as a "task recipe", per Josef's suggestion.

I believe it would help us all if we had some concrete terminology instead of generic "task yaml file" etc. A "task recipe" sounds reasonable, I believe.

Please go through our source code and documentation and adjust references to "task yaml" or "taskyaml" to "task recipe", or "task recipe yaml file" (if you want to be really specific).

Actions

This is a part of the rpmlint's recipe:

task:
    - name: download rpms from koji
      koji:
        action: download
        koji_build: ${koji_build}
        arch: ${arch}

    - name: run rpmlint on downloaded rpms
      python:
          file: run_rpmlint.py
          callable: run
          workdir: ${workdir}
      export: rpmlint_output

    - name: report results to resultsdb
      resultsdb:
          results: ${rpmlint_output}

The "task" key is a bit misleading as well. The whole file is a task recipe, and this just a single section of it. So it should not be named "task". In runner.py, Tim used the name "actions", and I like it. It is, in fact, a list of actions, and every action uses one of our directives. I'd replace task: with actions:.

Please go through our code and documentation and replace all references of task: section to actions: section.


If somebody has different suggestions for taskotron terminology, please speak up! Thanks.


This ticket had assigned some Differential requests:
D201

One possible issue is the conflict with beaker over the "recipe" term

The current proposal is formula and actions.

Metadata Update from @kparal:
- Issue tagged with: easyfix

6 years ago

Login to comment on this ticket.

Metadata