#194 Should load_rpmdefines be configuration, not code?
Opened 6 years ago by merlinthp. Modified 4 years ago

rpkg, fedpkg, centpkg all define their own version of the Commands.load_rpmdefines() function, with their own regexes, etc to parse out the relevant bits.

I use fed/rpkg with local git / koji infrastructure, and have various branches / disttag / koji tags that aren't in the existing code, so currently I have to patch it to add the relevant mappings. It'd be nice if that could be done in config instead.

How would we feel about that? I'm willing to work on a PR for it.

Relevant fedpkg request: https://pagure.io/fedpkg/pull-request/25

Do you have a proposal how to define the mapping in some config so that it's reasonably manageable?

No, not yet, I was going to see if there was interest in the idea before I spent too long on it. As there is, I'll have a closer look at the existing fedpkg code (it appears to be the most complex) and see if I can come up with a sane design for the config. Cheers!

IMO, it is worth to do it. @lsedlar probably we can move the implementation in rhpkg to rpkg as a general solution.

This issue has been unresolved for more than a year, and is going to be closed within a week if no further action is taken. If you feel this is in error, please contact me.
This is a cleaning process suggested by Jay Greguske. Copy of this ticket was already closed in JIRA tracker.

Login to comment on this ticket.