#9974 Error preinstalling rpm.rpm during osc build
Opened 4 months ago by dmccheyne. Modified 4 months ago

  • Describe the issue
    When calling an osc build command, preinstalling rpm fails with an error:
[    8s] [104/111] preinstalling rpm...
[    8s] error: /builds/app/app-ops/app-ctl/scratchbuild-Fedora_Rawhide-x86_64/.init_b_cache/rpms/rpm.rpm: signature hdr data: BAD, no. of bytes(30816) out of range
[    8s] error: /builds/app/app-ops/app-ctl/scratchbuild-Fedora_Rawhide-x86_64/.init_b_cache/rpms/rpm.rpm: not an rpm package (or package manifest)
[    8s] error: /builds/app/app-ops/app-ctl/scratchbuild-Fedora_Rawhide-x86_64/.init_b_cache/rpms/rpm.rpm: signature hdr data: BAD, no. of bytes(30816) out of range
[    8s] error reading header from package
  • When do you need this? (YYYY/MM/DD)
    2021-04-20 for Fedora 34 I suppose?

  • When is this no longer needed or useful? (YYYY/MM/DD)

  • If we cannot complete your request, what is the impact?
    Unknown

Build command: osc --config=/tmp/tmpg_n8o133.oscrc build --jobs=4 --local-package --alternative-project=MyCompany:Lego --trust-all-projects --no-verify --noservice   --root=/builds/app/app-ops/app-ctl/scratchbuild-Fedora_Rawhide-x86_64 Fedora_Rawhide x86_64 _service:set_version:_service:extract_file:app-ctl.spec
[    5s] [50/111] preinstalling libselinux...
[    6s] [51/111] preinstalling libxml2...
[    6s] [52/111] preinstalling perl-libs...
[    6s] [53/111] preinstalling perl-if...
[    6s] [54/111] preinstalling perl-parent...
[    6s] [55/111] preinstalling perl-subs...
[    6s] [56/111] preinstalling perl-Exporter...
[    6s] [57/111] preinstalling perl-interpreter...
[    6s] [58/111] preinstalling perl-mro...
[    6s] [59/111] preinstalling glibc-common...
[    6s] [60/111] preinstalling grep...
[    6s] [61/111] preinstalling sed...
[    6s] [62/111] preinstalling groff-base...
[    7s] [63/111] preinstalling p11-kit-trust...
[    7s] [64/111] preinstalling gawk...
[    7s] [65/111] preinstalling coreutils...
[    7s] [66/111] preinstalling perl-Carp...
[    7s] [67/111] preinstalling perl-Getopt-Std...
[    7s] [68/111] preinstalling perl-Symbol...
[    7s] [69/111] preinstalling perl-Term-ANSIColor...
[    7s] [70/111] preinstalling perl-Fcntl...
[    7s] [71/111] preinstalling perl-MIME-Base64...
[    7s] [72/111] preinstalling ca-certificates...
[    7s] [73/111] preinstalling perl-constant...
[    7s] [74/111] preinstalling perl-overloading...
[    7s] [75/111] preinstalling perl-vars...
[    7s] [76/111] preinstalling perl-Class-Struct...
[    7s] [77/111] preinstalling perl-Errno...
[    7s] [78/111] preinstalling perl-File-Basename...
[    7s] [79/111] preinstalling perl-SelectSaver...
[    7s] [80/111] preinstalling perl-Text-ParseWords...
[    7s] [81/111] preinstalling openssl-libs...
[    7s] [82/111] preinstalling perl-Digest...
[    7s] [83/111] preinstalling perl-Scalar-List-Utils...
[    7s] [84/111] preinstalling perl-Socket...
[    7s] [85/111] preinstalling perl-POSIX...
[    7s] [86/111] preinstalling perl-Pod-Escapes...
[    7s] [87/111] preinstalling perl-Text-Tabs+Wrap...
[    7s] [88/111] preinstalling perl-Digest-MD5...
[    7s] [89/111] preinstalling perl-Term-Cap...
[    8s] [90/111] preinstalling perl-overload...
[    8s] [91/111] preinstalling perl-Time-Local...
[    8s] [92/111] preinstalling perl-PathTools...
[    8s] [93/111] preinstalling libarchive...
[    8s] [94/111] preinstalling krb5-libs...
[    8s] [95/111] preinstalling rpm-libs...
[    8s] [96/111] preinstalling libcurl-minimal...
[    8s] [97/111] preinstalling perl-File-Path...
[    8s] [98/111] preinstalling perl-File-stat...
[    8s] [99/111] preinstalling perl-Encode...
[    8s] [100/111] preinstalling curl-minimal...
[    8s] [101/111] preinstalling perl-IO...
[    8s] [102/111] preinstalling perl-podlators...
[    8s] [103/111] preinstalling perl-Storable...
[    8s] [104/111] preinstalling rpm...
[    8s] error: /builds/app/app-ops/app-ctl/scratchbuild-Fedora_Rawhide-x86_64/.init_b_cache/rpms/rpm.rpm: signature hdr data: BAD, no. of bytes(30816) out of range
[    8s] error: /builds/app/app-ops/app-ctl/scratchbuild-Fedora_Rawhide-x86_64/.init_b_cache/rpms/rpm.rpm: not an rpm package (or package manifest)
[    8s] error: /builds/app/app-ops/app-ctl/scratchbuild-Fedora_Rawhide-x86_64/.init_b_cache/rpms/rpm.rpm: signature hdr data: BAD, no. of bytes(30816) out of range
[    8s] error reading header from package
[    8s] [105/111] preinstalling perl-HTTP-Tiny...
[    8s] [106/111] preinstalling perl-IPC-Open3...
[    8s] [107/111] preinstalling perl-File-Temp...
[    8s] [108/111] preinstalling perl-Pod-Perldoc...
[    8s] [109/111] preinstalling perl-Pod-Usage...
[    8s] [110/111] preinstalling perl-Getopt-Long...
[    8s] [111/111] preinstalling perl-Pod-Simple...
[    9s] 
[    9s] initializing rpm db...
[    9s] chroot: failed to run command 'rpm': No such file or directory

What os are you running this on? Can you tell what version of the rpm rpm it has?

Metadata Update from @smooge:
- Issue tagged with: medium-gain, medium-trouble, ops

4 months ago

This is running on a CentOS 8 container (in the context of a gitlab CI pipeline FWIW)
It has RPM version 4.14.2

Can you please re-try with the latest rawhide?

No change with the latest.

Login to comment on this ticket.

Metadata
Boards 1
Ops Status: Backlog