#9915 epel-release-latest-8 link broken
Closed: Fixed 7 months ago by mohanboddu. Opened 8 months ago by kevin.

See:

https://bugzilla.redhat.com/show_bug.cgi?id=1909581

Likely this is a bug in the new-updates-sync script that was recently changed to update these links. ;(

@mohanboddu can you look ?


cd /pub/epel/
ls -la
lrwxrwxrwx. 1 ftpsync ftpsync       49 Aug  5  2019 epel-release-latest-6.noarch.rpm -> ./6/x86_64/Packages/e/epel-release-6-8.noarch.rpm
lrwxrwxrwx. 1 ftpsync ftpsync       48 Dec  1 18:35 epel-release-latest-7.noarch.rpm -> 7/x86_64/Packages/e/epel-release-7-13.noarch.rpm
lrwxrwxrwx. 1 ftpsync ftpsync       62 Dec  1 18:36 epel-release-latest-8.noarch.rpm -> 8/Everything/x86_64/Packages/e/epel-release-8-9.el8.noarch.rpm
# ls -la 8/Everything/x86_64/Packages/e/epel-release-8-10.el8.noarch.rpm 
-rw-r--r--. 1 ftpsync ftpsync 22576 Dec  5 21:16 8/Everything/x86_64/Packages/e/epel-release-8-10.el8.noarch.rpm

I'm going to manually fix the 8 link so it doesn't break people's CI.

Likely this is a bug in the new-updates-sync script that was recently changed to update these links. ;(

@kevin That might not be the case, as my new PR hasn't merged yet and the old PR got reverted. This probably happened because there was a new epel-release-8 build and the symlink wasn't updated manually after that build is pushed.

Once my PR is merged that should solve this issue.

Metadata Update from @mohanboddu:
- Issue tagged with: dev, low-trouble, medium-gain, ops

8 months ago

Ah, my mistake. Lets get it merged in the new year. ;)

Closing this ticket for now as I think its fixed now, we will see if it breaks when there is a next epel release.

Metadata Update from @mohanboddu:
- Issue close_status updated to: Fixed
- Issue status updated to: Closed (was: Open)

7 months ago

Login to comment on this ticket.

Metadata
Boards 2
Ops Status: Backlog
Dev Status: Done