#6359 Broken "Broken dependencies" report about noarch package with ExclusiveArch
Closed: Duplicate 3 years ago Opened 4 years ago by ppisar.

I have perl-Dumbbench source package that produces noarch perl-Dumbbench-!BoxPlot package. The package run-requires perl-SOOT that is not available on ARM.

Therefore I added an !ExclusiveArch statement into the perl-Dumbbench-!BoxPlot package to prevent from including the package into ARM composes:

{{{
ExclusiveArch: %{ix86} x86_64 noarch
}}}

This is in line packaging guidelines [https://fedoraproject.org/wiki/Packaging:Guidelines#Requires] and it worked for many years.

But today, I received this e-mail:

{{{
Date: Mon, 29 Feb 2016 22:05:02 +0000 (UTC)
From: buildsys@fedoraproject.org
To: perl-Dumbbench-owner@fedoraproject.org
Cc:
Subject: Broken dependencies: perl-Dumbbench

perl-Dumbbench has broken dependencies in the rawhide tree:
On armhfp:
perl-Dumbbench-BoxPlot-0.10-2.fc24.noarch requires perl(SOOT)
}}}

I believe a flaw has been introduced into your compose process. Could you fix it?


Something has changed in Koji. Now even Koji does not understand the semantics and tries to schedule the builds to non-listed platforms (armv7hl). You can see the random build failures started on 2016-04-01 https://apps.fedoraproject.org/koschei/package/perl-Dumbbench.

koji looks at it and says because of "BuildArch: noarch" it can build it anywhere. this has always been the case.

No or everybody was very lucky till now. Please see the linked Koschei history. Moreover Packaging guidelines documents this feature.

Metadata Update from @ppisar:
- Issue set to the milestone: Fedora 24 Alpha

3 years ago

Any progress? This is still issue, e.g. with perl-Alien-ROOT https://apps.fedoraproject.org/koschei/package/perl-Alien-ROOT?collection=f27 which noarch package run-time depending on a package unavailable on PowerPC.

Metadata Update from @ppisar:
- Issue close_status updated to: None

3 years ago

Koji fix was already merged and it will be part of next upstream release (April). https://pagure.io/koji/c/55d57495

Any progress? I still get the reports and moreover "Retiring Packages with Broken Dependencies in branched (2017-06-12)" https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/thread/6CZUFQZKUVWPOMXNILQDHGZK7XCUXCSN/ lists perl-Alient-ROOT as a package scheduled for retiring. I would be very displeased if the package were retired.

Isn't this the same case as https://pagure.io/pungi-fedora/issue/87?

Isn't this the same case as https://pagure.io/pungi-fedora/issue/87?

Thank you, yes, it looks like a duplicate to me. This would need to be changed in pungi.

Metadata Update from @till:
- Issue close_status updated to: Duplicate
- Issue status updated to: Closed (was: Open)

3 years ago

Login to comment on this ticket.

Metadata