#6335 Please untag xmlada-2015-8.fc24.
Closed: Invalid None Opened 6 years ago by rombobeorn.

I would like to have xmlada-2015-8.fc24 removed from Rawhide and xmlada-2015-7.fc23 reinstated, please. I think this is the place to request such things?

It turns out that XMLada segfaults if it's been built with gcc-5.3.1-3.fc24 or gcc-5.3.1-2.fc23, but it works if built with gcc-5.1.1-4.fc23. The broken package prevents further builds in Koji because it's build-time dependent on itself, so I need to get it removed.

Then I'll need a way to get a working package built before GCC 6 lands in Rawhide. Can a buildroot override replace a package with an older version? Would it be OK if I'd make a buildroot override with GCC 5.1.1 for a short while?


We can't go backwards once it's out on the mirror because people that have already upgraded it won't get the older version.

You need to drop out the changes and bump the NVR and rebuild.

Then I'll have to resort to bootstrapping to get things working again.

Replying to [comment:2 rombobeorn]:

Then I'll have to resort to bootstrapping to get things working again.

When you do can you add a bootstrap flag itno the rpm spec file to make it easy to boot strap new architectures too and make the process easier in the future?

Metadata Update from @rombobeorn:
- Issue set to the milestone: Fedora 24 Alpha

4 years ago

Login to comment on this ticket.

Metadata