#6161 soname version bump of gnutls,nettle in rawhide
Closed: Fixed None Opened 5 years ago by nmav.

Hello,
I open this ticket due to Updates_Policy. I'd like to update nettle and gnutls to their latest versions in rawhide. This would require a mass rebuild of the packages shown by:
repoquery --whatrequires gnutls
repoquery --whatrequires nettle

Please advise on the process. I plan to update the packages next week.


There seems to be discussion on the list that a compat package will help this out and not require some flag day/mass rebuild.

Please formulate the plan on the list first...

Replying to [comment:1 kevin]:

There seems to be discussion on the list that a compat package will help this out and not require some flag day/mass rebuild.

That's what's happened in the past with libpng and others, plus it should be done in a side tag first (both compat package and new builds) and then tagged in so rawhide isn't broken for days

The discussion in the list is not very relevant to this request. The discussion in the list is about a compat package for gnutls (only) to handle non-fedora applications. Fedora applications will have to be recompiled with the new gnutls package anyway. Moreover there will be no compat package for nettle.

The right course of action really depends on the numbers of packages effected, how much porting work needs to be done, and if bumping the soname breaks the minimal buildroot or srpm creation.

{{{
repoquery --whatrequires libgnutls.so.28()(64bit) --disablerepo=* --enablerepo=fedora

Yum-utils package has been deprecated, use dnf instead.
See 'man yum2dnf' for more information.

aiccu-0:2007.01.15-22.fc22.x86_64
aqbanking-0:5.5.1-1.fc22.x86_64
aria2-0:1.18.6-2.fc22.x86_64
aws-0:3.1.0-12.fc22.x86_64
aws-devel-0:3.1.0-12.fc22.x86_64
aws-tools-0:3.1.0-12.fc22.x86_64
cairo-dock-plug-ins-base-0:3.4.1-3.fc22.x86_64
claws-mail-0:3.11.1-6.fc22.x86_64
claws-mail-plugins-acpi-notifier-0:3.11.1-6.fc22.x86_64
claws-mail-plugins-address-keeper-0:3.11.1-6.fc22.x86_64
claws-mail-plugins-archive-0:3.11.1-6.fc22.x86_64
claws-mail-plugins-att-remover-0:3.11.1-6.fc22.x86_64
claws-mail-plugins-attachwarner-0:3.11.1-6.fc22.x86_64
claws-mail-plugins-bogofilter-0:3.11.1-6.fc22.x86_64
claws-mail-plugins-bsfilter-0:3.11.1-6.fc22.x86_64
claws-mail-plugins-clamd-0:3.11.1-6.fc22.x86_64
claws-mail-plugins-fancy-0:3.11.1-6.fc22.x86_64
claws-mail-plugins-fetchinfo-0:3.11.1-6.fc22.x86_64
claws-mail-plugins-gdata-0:3.11.1-6.fc22.x86_64
claws-mail-plugins-libravatar-0:3.11.1-6.fc22.x86_64
claws-mail-plugins-mailmbox-0:3.11.1-6.fc22.x86_64
claws-mail-plugins-newmail-0:3.11.1-6.fc22.x86_64
claws-mail-plugins-notification-0:3.11.1-6.fc22.x86_64
claws-mail-plugins-pdf-viewer-0:3.11.1-6.fc22.x86_64
claws-mail-plugins-perl-0:3.11.1-6.fc22.x86_64
claws-mail-plugins-pgp-0:3.11.1-6.fc22.x86_64
claws-mail-plugins-python-0:3.11.1-6.fc22.x86_64
claws-mail-plugins-rssyl-0:3.11.1-6.fc22.x86_64
claws-mail-plugins-smime-0:3.11.1-6.fc22.x86_64
claws-mail-plugins-spam-report-0:3.11.1-6.fc22.x86_64
claws-mail-plugins-spamassassin-0:3.11.1-6.fc22.x86_64
claws-mail-plugins-tnef-0:3.11.1-6.fc22.x86_64
claws-mail-plugins-vcalendar-0:3.11.1-6.fc22.x86_64
connman-0:1.25-1.fc22.x86_64
csync2-0:1.34-15.fc22.x86_64
cups-1:2.0.2-5.fc22.x86_64
cups-libs-1:2.0.2-5.fc22.x86_64
dwb-0:2014.03.07-4.fc22.x86_64
ekg2-jabber-0:0.3.1-14.fc22.x86_64
emacs-1:24.5-2.fc22.x86_64
emacs-nox-1:24.5-2.fc22.x86_64
empathy-0:3.12.9-1.fc22.x86_64
filezilla-0:3.10.3-1.fc22.x86_64
freeDiameter-0:1.2.0-6.fc22.x86_64
freetds-0:0.91-15.git0a42888.fc22.x86_64
glib-networking-0:2.44.0-1.fc22.x86_64
glib-networking-tests-0:2.44.0-1.fc22.x86_64
gloox-1:1.0.13-1.fc22.x86_64
gnome-color-manager-0:3.16.0-1.fc22.x86_64
gnome-terminal-0:3.16.1-1.fc22.x86_64
gnomint-0:1.2.1-126.fc22.x86_64
gnustep-base-libs-0:1.24.7-2.fc22.x86_64
gnutls-c++-0:3.3.14-1.fc22.x86_64
gnutls-dane-0:3.3.14-1.fc22.x86_64
gnutls-guile-0:3.3.14-1.fc22.x86_64
gnutls-utils-0:3.3.14-1.fc22.x86_64
gobby05-0:0.5.0-1.fc22.x86_64
gtk-gnutella-0:1.1.1-1.fc22.x86_64
gtk-vnc-0:0.5.4-1.fc22.x86_64
gtk-vnc-python-0:0.5.4-1.fc22.x86_64
gtk-vnc2-0:0.5.4-1.fc22.x86_64
gvnc-0:0.5.4-1.fc22.x86_64
gvnc-tools-0:0.5.4-1.fc22.x86_64
gvncpulse-0:0.5.4-1.fc22.x86_64
gwenhywfar-0:4.13.1-2.fc22.x86_64
htmldoc-0:1.8.28-5.fc22.x86_64
httpress-0:1.1.0-3.fc22.x86_64
iksemel-0:1.4-10.fc22.x86_64
iksemel-utils-0:1.4-10.fc22.x86_64
infinoted-0:0.6.4-1.fc22.x86_64
jd-0:2.8.9-1.fc22.x86_64
kazehakase-base-0:0.5.8-18.svn3873_trunk.fc22.x86_64
kazehakase-ruby-0:0.5.8-18.svn3873_trunk.fc22.x86_64
lftp-0:4.6.1-4.fc22.x86_64
libabiword-1:3.0.1-2.fc22.x86_64
libcacard-tools-2:2.3.0-0.5.rc3.fc22.x86_64
libepc-0:0.4.0-8.fc22.x86_64
libepc-ui-0:0.4.0-8.fc22.x86_64
libetpan-0:1.6-2.fc22.x86_64
libgadu-0:1.12.1-1.fc22.x86_64
libimobiledevice-0:1.2.0-1.fc22.x86_64
libimobiledevice-utils-0:1.2.0-1.fc22.x86_64
libinfinity-0:0.6.4-1.fc22.x86_64
libinfinity-gtk-0:0.6.4-1.fc22.x86_64
libmicrohttpd-0:0.9.39-2.fc22.x86_64
librelp-0:1.2.7-3.fc22.x86_64
libvirt-client-0:1.2.13-3.fc22.x86_64
libvirt-daemon-0:1.2.13-3.fc22.x86_64
libvirt-daemon-driver-lxc-0:1.2.13-3.fc22.x86_64
libvirt-daemon-driver-qemu-0:1.2.13-3.fc22.x86_64
libvirt-lock-sanlock-0:1.2.13-3.fc22.x86_64
libvncserver-0:0.9.10-0.6.20140718git9453be42.fc22.x86_64
libyaz-0:5.8.1-2.fc22.x86_64
licq-0:1.8.2-5.fc22.x86_64
loudmouth-0:1.4.3-15.fc22.x86_64
mod_gnutls-0:0.6-1.fc22.x86_64
mpop-0:1.0.29-3.fc22.x86_64
msmtp-0:1.4.32-3.fc22.x86_64
mutt-5:1.5.23-7.fc22.x86_64
ncdc-0:1.19.1-2.fc21.x86_64
net6-0:1.3.14-7.fc22.x86_64
ngircd-0:22-2.fc22.x86_64
nntpgrab-core-0:0.7.2-9.fc22.x86_64
nntpgrab-server-0:0.7.2-9.fc22.x86_64
nntpgrab-server-gtk-0:0.7.2-9.fc22.x86_64
ntfsprogs-2:2015.3.14-1.fc22.x86_64
ocserv-0:0.10.2-1.fc22.x86_64
openconnect-0:7.06-1.fc22.x86_64
openvas-cli-0:1.3.1-1.fc22.x86_64
openvas-libraries-0:7.0.6-1.fc22.x86_64
openvas-manager-0:5.0.7-1.fc22.x86_64
openvas-scanner-0:4.0.5-1.fc22.x86_64
pacemaker-0:1.1.12-2.fc22.x86_64
pacemaker-cli-0:1.1.12-2.fc22.x86_64
pacemaker-cluster-libs-0:1.1.12-2.fc22.x86_64
pacemaker-cts-0:1.1.12-2.fc22.x86_64
pacemaker-libs-0:1.1.12-2.fc22.x86_64
pacemaker-remote-0:1.1.12-2.fc22.x86_64
postal-0:0.70-14.fc22.x86_64
pwmd-0:3.0.7-1.fc22.x86_64
qemu-common-2:2.3.0-0.5.rc3.fc22.x86_64
qemu-img-2:2.3.0-0.5.rc3.fc22.x86_64
qemu-system-aarch64-2:2.3.0-0.5.rc3.fc22.x86_64
qemu-system-alpha-2:2.3.0-0.5.rc3.fc22.x86_64
qemu-system-arm-2:2.3.0-0.5.rc3.fc22.x86_64
qemu-system-cris-2:2.3.0-0.5.rc3.fc22.x86_64
qemu-system-lm32-2:2.3.0-0.5.rc3.fc22.x86_64
qemu-system-m68k-2:2.3.0-0.5.rc3.fc22.x86_64
qemu-system-microblaze-2:2.3.0-0.5.rc3.fc22.x86_64
qemu-system-mips-2:2.3.0-0.5.rc3.fc22.x86_64
qemu-system-moxie-2:2.3.0-0.5.rc3.fc22.x86_64
qemu-system-or32-2:2.3.0-0.5.rc3.fc22.x86_64
qemu-system-ppc-2:2.3.0-0.5.rc3.fc22.x86_64
qemu-system-s390x-2:2.3.0-0.5.rc3.fc22.x86_64
qemu-system-sh4-2:2.3.0-0.5.rc3.fc22.x86_64
qemu-system-sparc-2:2.3.0-0.5.rc3.fc22.x86_64
qemu-system-tricore-2:2.3.0-0.5.rc3.fc22.x86_64
qemu-system-unicore32-2:2.3.0-0.5.rc3.fc22.x86_64
qemu-system-x86-2:2.3.0-0.5.rc3.fc22.x86_64
qemu-system-xtensa-2:2.3.0-0.5.rc3.fc22.x86_64
rnetclient-0:2015.1-1.fc22.x86_64
rsyslog-gnutls-0:8.8.0-2.fc22.x86_64
samba-client-libs-2:4.2.1-4.fc22.x86_64
sflphone-libs-0:1.4.1-7.fc22.x86_64
sslogger-0:0.96-13.fc22.x86_64
sslogger-slogd-0:0.96-13.fc22.x86_64
systemd-journal-gateway-0:219-9.fc22.x86_64
task-0:2.4.2-1.fc22.x86_64
taskd-0:1.0.0-10.fc22.x86_64
telepathy-gabble-0:0.18.2-4.fc22.x86_64
telepathy-salut-0:0.8.1-7.fc22.x86_64
tigervnc-0:1.4.3-4.fc22.x86_64
tigervnc-server-0:1.4.3-4.fc22.x86_64
tigervnc-server-minimal-0:1.4.3-4.fc22.x86_64
tigervnc-server-module-0:1.4.3-4.fc22.x86_64
tomahawk-libs-0:0.8.2-3.fc22.x86_64
vinagre-0:3.16.0-2.fc22.x86_64
vino-0:3.16.0-1.fc22.x86_64
vpnc-0:0.5.3-25.svn550.fc22.x86_64
vte291-0:0.40.0-1.fc22.x86_64
vte291-devel-0:0.40.0-1.fc22.x86_64
weechat-0:1.1.1-1.fc22.x86_64
wireshark-0:1.12.4-1.fc22.x86_64
xen-runtime-0:4.5.0-8.fc22.x86_64
xfce4-mailwatch-plugin-0:1.2.0-6.fc22.x86_64
xmlsec1-gnutls-0:1.2.20-1.fc22.x86_64
}}}

{{{
repoquery --whatrequires libhogweed.so.2()(64bit) libnettle.so.4()(64bit) --disablerepo=* --enablerepo=fedora

Yum-utils package has been deprecated, use dnf instead.
See 'man yum2dnf' for more information.

dnsmasq-0:2.72-3.fc22.x86_64
gnutls-0:3.3.14-1.fc22.x86_64
gnutls-utils-0:3.3.14-1.fc22.x86_64
nettle-devel-0:2.7.1-5.fc22.x86_64
stoken-cli-0:0.81-2.fc22.x86_64
stoken-gui-0:0.81-2.fc22.x86_64
stoken-libs-0:0.81-2.fc22.x86_64
aria2-0:1.18.6-2.fc22.x86_64
dnsmasq-0:2.72-3.fc22.x86_64
freeradius-client-0:1.1.7-6.fc22.x86_64
gnutls-0:3.3.14-1.fc22.x86_64
gnutls-utils-0:3.3.14-1.fc22.x86_64
gstreamer1-plugins-bad-free-0:1.4.5-2.fc22.x86_64
nettle-devel-0:2.7.1-5.fc22.x86_64
stoken-cli-0:0.81-2.fc22.x86_64
stoken-gui-0:0.81-2.fc22.x86_64
stoken-libs-0:0.81-2.fc22.x86_64
tigervnc-server-minimal-0:1.4.3-4.fc22.x86_64
}}}

gnutls does not end up in the minimal buildroot. given the number of packages that will need to be rebuilt I would suggest you request a side tag unless you are 100% confident that you can rebuild everything in a single day.

I am not 100% confident that everything will rebuild. If a side tag must be done first then please consider this request as asking a sidetag for the gnutls rebuild.

I have created a f23-gnutls tag/target for you. you can initiate builds with

{{{
$ fedpkg build --target=f23-gnutls
}}}

Please let us know when you have everything built so that we can merge the builds into rawhide and delete the target

I have managed to put gnutls, compat-gnutls28 and nettle into the new f23-gnutls, but compiling other packages isn't possible. Except for a few which didn't have a version in rawhide, I get:
{{{
$ fedpkg build --target=f23-gnutls
Could not execute build: Package freeradius-client-1.1.7-6.fc23 has already been built
Note: You can skip this check with --skip-nvr-check. See help for more info.
}}}

Replying to [comment:7 nmav]:

I have managed to put gnutls, compat-gnutls28 and nettle into the new f23-gnutls, but compiling other packages isn't possible. Except for a few which didn't have a version in rawhide, I get:

You need to bump the package NVR when rebuilding packages against a new library.

That's something I cannot do. I don't have access to all these packages.

Replying to [comment:9 nmav]:

That's something I cannot do. I don't have access to all these packages.

How have you done it in the past for gnutls rebuilds then?

Thanks to the gnutls compat package, I believe there's only a handful of packages that need to be rebuilt before the side tag can be merged back into rawhide proper. Anything linking with gnutls should be fine and only the packages that link with the previous libnettle would have to be rebuilt:

{{{
$ repoquery -q --disablerepo='*' --enablerepo=rawhide-koji --whatrequires 'libnettle.so.4()(64bit)' -s | sort | uniq
aria2-1.18.10-3.fc23.src.rpm
freeradius-client-1.1.7-6.fc23.src.rpm
gstreamer1-plugins-bad-free-1.4.5-4.fc23.src.rpm
knot-1.99.1-2.fc23.src.rpm
ocaml-ocamlnet-4.0.1-2.fc23.src.rpm
stoken-0.81-3.fc23.src.rpm
tigervnc-1.4.3-7.fc23.src.rpm
}}}

I can kick the builds for these off now if you want?

@pbrobinson: I haven't done it in the past. That's the reason of this ticket.

@Kalev, that would be great.

OK, builds done. Of the 7 above, 2 failed:

The 2nd one in particular would be good to fix before merging the builds back, since tigervnc-server-minimal is on the Workstation image.

I've submitted a bug for the tigervnc.
https://bugzilla.redhat.com/show_bug.cgi?id=1218518

The ocaml-ocamlnet issue looks quite strange as it seems that the failing program is an auto-generated one which used the old headers. I'll address that missing definition in the gnutls package, so that this would compile as well.

Thanks, tigervnc-1.4.3-9.fc23 built with the patch. I think it should be fine to merge the builds back to rawhide proper now -- should I do that?

It would be ok with me.

OK, all builds moved to f23.

dgilmore: All done here, should be fine to remove the build target now.

kalev you broke our processes by movingf builds. please do not do it again.

the f23-gnutls target has been removed. but due to kalevs actions we can not report on what was actually moved over.

It seems there are issues with programs and libraries being slowly compiled to use the new library. Some applications cannot cope with multiple versions of the same library (see #1230889). Please reopen this and schedule a recompilation of the components listed above.

Replying to [comment:19 nmav]:

It seems there are issues with programs and libraries being slowly compiled to use the new library. Some applications cannot cope with multiple versions of the same library (see #1230889). Please reopen this and schedule a recompilation of the components listed above.

Is there still anything that needs a rebuild?

Login to comment on this ticket.

Metadata