#4932 Rebuild for certain Java dependent packages in F16
Closed: Fixed None Opened 8 years ago by dbhole.

Hi,

This bug is related to FESCo ticket 663:
https://fedorahosted.org/fesco/ticket/663

We've decided that everything in Fedora should be built with 1.6 and to that end, I built a new version of java-1.7.0-openjdk on August 29th that no longer satisfies 'java' or 'java-devel' dependencies. Because java-1.7.0-openjdk actively satisfied 'java' and 'java-devel' dependencies before, the packages built when that package was in koji need to be rebuilt.


Please see attached file for list of Java dependent packages built in 2011. Based on that, the following need to be rebuilt:

2011-08-09 colossus-0.12.2-0.1.svn5033.fc16.src
2011-08-09 jpanoramamaker-5-5.fc16.src
2011-08-09 link-grammar-4.7.4-1.fc16.src
2011-08-09 R-2.13.1-4.fc16.src
2011-08-10 0:xalan-j2-2.7.1-6.fc16.src
2011-08-11 freewrl-1.22.12-0.3.pre2.fc16.src
2011-08-11 jopt-simple-3.3-3.fc16.src
2011-08-12 java-service-wrapper-3.2.5-5.fc16.src
2011-08-12 maven-reporting-exec-1.0.1-3.fc16.src
2011-08-15 0:tomcat-7.0.20-3.fc16.src
2011-08-15 apache-commons-daemon-1.0.7-1.fc16.src
2011-08-15 postgresql-jdbc-9.0.801-4.fc16.src
2011-08-16 httpcomponents-client-4.1.2-1.fc16.src
2011-08-16 httpcomponents-core-4.1.3-1.fc16.src
2011-08-16 webkitgtk3-1.5.2-1.fc16.src
2011-08-17 1:libguestfs-1.12.4-1.fc16.src
2011-08-17 gnumed-0.9.9-4.fc16.src
2011-08-17 plplot-5.9.8-2.fc16.src
2011-08-17 sblim-cim-client2-2.1.9-2.fc16.src
2011-08-20 1:mysql-connector-java-5.1.17-1.fc16.src
2011-08-22 maven-3.0.3-13.fc16.src
2011-08-22 sisu-2.2.3-2.fc16.src
2011-08-24 gcc-4.6.1-8.fc16.src
2011-08-24 jnr-ffi-0.5.10-3.fc16.src
2011-08-24 pl-5.10.2-5.fc16.src
2011-08-26 1:libgda-4.2.8-1.fc16.src
2011-08-27 azureus-4.6.0.4-4.fc16.src
2011-08-27 nordugrid-arc-1.0.1-3.fc16.src

Only a release bump+rebuild is required. Could someone from rel-eng automate these rebuilds in F-16? It'd make things much easier. Feel free to direct any build failures to me (dbhole@redhat.com). Though I don't expect any..

Sorry, list of files didn't get pasted properly. Please see the second attachment "java-packages-requiring-rebuild" for the list.

Any movement here from rel-eng?

fwiw, imo, yada yada, this task could be accomplished by any provenpackager... (no?)

OK, I can do these... I'll leave out gcc for now, as there's a newer gcc-4.6.1-9.fc16 now (I'll double-check that after I do the others)

leaving gcc out for good, I don't see any java-devel or openjdk in it's buildroot (curious, how did you generate this list of things to rebuild anyway?)

dbhole,
first failure (haven't looked at it myself yet):
freewrl-1.22.12-0.3.pre2.fc16.1
http://koji.fedoraproject.org/koji/taskinfo?taskID=3400589

Just for the record this type of rebuild is not normally a releng issue at all. rebuilds like this are normally done by the team maintaining those pieces of software. we normally only handle full distro mass rebuilds.

Thanks Rex for doing it.

builds done, update submitted,
https://admin.fedoraproject.org/updates/webkitgtk3-1.5.90-1.fc16.1

Well, sans libgda, which appears to have a semi-long-standing FTBFS (DSO?) problem

Well, sans libgda, which appears to have a semi-long-standing FTBFS (DSO?) problem

The root.log for libgda-4.2.8-1.fc16 shows that java-1.6.0-openjdk-devel was used (not 1.7.0), so a rebuild is not needed for libgda anyway.

Metadata Update from @dbhole:
- Issue set to the milestone: Fedora 16 Beta

3 years ago

Login to comment on this ticket.

Metadata