#4859 task#23: Create Fedora 16 Alpha release candidate (RC) - live and traditional

Created 5 years ago by adamwill
Modified 4 months ago

Adding:
* https://admin.fedoraproject.org/updates/anaconda-16.14.2-1.fc16 for several EFI related NTH fixes
* http://bugzilla.redhat.com/727933 - Installing onto an EFI system from an EFI USB stick fails when trying to use /boot/efi from the USB
* http://bugzilla.redhat.com/728007 - EFI install fails with traceback - TypeError: '_sre.SRE_Match' object is not subscriptable
* http://bugzilla.redhat.com/728015 - EFI Install fails with _non_linux_format_types error

Okay, I think we now have all the updates required for RC cookin, though some may still need karma. Here's the full list:

Blocker fixes

all for https://bugzilla.redhat.com/show_bug.cgi?id=727401 [[BR]]

NTH fixes

https://bugzilla.redhat.com/show_bug.cgi?id=727951 remains an open acceptednth; there's a patch under review at present apparently. Don't know how quickly anaconda team might add it.

all updates have at least +1 proventester (which I believe is all that's required at this stage) except the anaconda update.

http://dl.fedoraproject.org/pub/alt/stage/16-Alpha.RC1/

I added https://admin.fedoraproject.org/updates/abiword-2.8.6-12.fc16 to fix the dep issues on the XFCE live cds LXDE is currently not building due to a broken dep.

As discussed at the QA group meeting this morning, we will need an RC2, as further release blocker bugs have surfaced in RC1. Some do not have fixes yet, so we are not yet ready to compose RC2, but the current list of fixes to be pulled in is:

We will be working to ensure updates are provided for the currently un-fixed blockers.

also need to block report and ensure kdesdk-4.6.95 is not available in the compose repository to try and address file conflict blockers.

With the above two comments, that should be the full list for RC2. Thanks!

livecds are now up

We will need an RC4; there are numerous blockers in RC3.

The following bugs are accepted blockers that were not addressed in RC3, as of right now:

These will definitely need fixes for RC4.

The following are proposed blockers not addressed in RC3:

So if they are accepted as blockers in Friday's review meeting, we'll need fixes for those too.

As of now, the only fix available is:

I will update as fixes become available, and provide a summary post listing all packages to pull (including any NTH) once all blocker fixes are available.

So, we're ready to spin RC4. Here's the full recipe, based on open blockers - I'm assuming all closed blockers are now fixed in the public repos:

Blocker fixes

NTH fixes

Important note: do not pull https://admin.fedoraproject.org/updates/dracut-013-1.fc16 , it contains extra non-blocker fix changes compared to https://admin.fedoraproject.org/updates/dracut-011-41.git20110810 , and is believed to have bugs. https://admin.fedoraproject.org/updates/dracut-011-41.git20110810 is sufficient to fix all known blockers, please use that one.

Again, block report-* and ensure kdesdk-4.6.95 is not available in the compose repository to avoid file conflicts.

Thanks!

Oh, whoops - missed one NTH:

https://admin.fedoraproject.org/updates/osmo-0.2.12-0.1.svn924.fc16 for https://bugzilla.redhat.com/show_bug.cgi?id=729845 (allows LXDE live to compose, should not affect anything else as no-one else uses it)

4 months ago

Metadata Update from @adamwill:
- Issue assigned to ausil
- Issue set to the milestone: Fedora 16 Alpha

Login to comment on this ticket.

cancel