#3729 unblock package perl-version in cvs
Closed: Fixed None Opened 11 years ago by mmaslano.

This package lives again. Please unblock cvs in all needed branches: F-12 F-13, F-14.
Bugzilla ticket with review of package perl-version:
https://bugzilla.redhat.com/show_bug.cgi?id=579682


Now blocked in dist-f14, fyi. C.f. bugzilla bug #633775.

Could you please unblock perl-version package again even for F-14? There does not exist any problem.
In the bug report mentioned above was confusion about internal version module from perl core, which is noarch. The perl-version package has defined arch, because it contains new arch dependent sub-module. This works as it should work, but from the start of the bugzilla, it could be seen as odd.

OK. Note that if it's never been pushed as an update, nothing will happen in the repos for F-14.

It's still deprecated in rawhide.

$ koji unblock-pkg dist-f15 perl-version
GenericError: package perl-version NOT blocked in tag dist-f15

Seems OK to me.

For rawhide it's set to deprecated & orphaned in pkgdb. It might not be deprecated in koji, but it seems to be according pkgdb. Also we (mmaslano, ppisar, psabata) need to be added as maintainers.

Seems like the way forward, is to unorphan it. go into pkgdb, and take over ownership.

http://fedoraproject.org/wiki/Orphaned_package_that_need_new_maintainers

Replying to [comment:8 rdieter]:

Seems like the way forward, is to unorphan it. go into pkgdb, and take over ownership.

http://fedoraproject.org/wiki/Orphaned_package_that_need_new_maintainers

Sadly, that's not possible otherwise I would follow this process. On the list of orphaned packages is perl-version not mentioned, see https://admin.fedoraproject.org/pkgdb/acls/orphans

It's probably because web gui of pkgdb is telling us deprecated & orphaned. This is probably a bug in pkgdb or in process.

I took care of this because I saw it. The current way we do changes to package ownership is via CVSAdmin requests:

https://fedoraproject.org/wiki/Package_SCM_admin_requests

Maybe we should think about purposefully making the set of rel-engs and cvsadmins overlap and creating a single set of instructions so that a maintainer can submit the change in one place and then the people in charge of the tools can make the necessary changes everywhere.

Thank you. I've asked as I should about permission in bugzilla https://bugzilla.redhat.com/show_bug.cgi?id=228433, but there were some mistakes which leads to this ticket.

It might be good to change a little the procedure. The rel-eng requests and SCM admin request might be confusing for people who want create only one package per year or even less often.

Login to comment on this ticket.

Metadata