#3239 deltarpm missing for eclipse update (F12) - 3.5.1-20 => -21
Closed: Duplicate None Opened 11 years ago by bbaetz.

An update to eclipse was pushed today, however the eclipse packages don't have the appropriate drpms available.

A drpm is available from the 'base' eclipse-jdt-3.5.1-4.fc12, but not from the last update to -20 (https://admin.fedoraproject.org/updates/F12/FEDORA-2009-11860)

For example, I had eclipse-jdt-3.5.1-20.fc12.x86_64.rpm installed. /fedora/linux/updates/12/x86_64/drpms/ on my local mirror has eclipse-jdt-3.5.1-4.fc12_3.5.1-21.fc12.x86_64.drpm but no other relevant file.

I can generate a drpm locally using makedeltarpm, and apply it to the koji (unsigned) -20 package to get an identical package. This means that I have to download a 24M package rather than a 94k drpm. (Similarly for the 27M eclipse-platform package)

Some packages (eg NetworkManager) do have a drpm from both the initial version and the previous updated version.

I've seen this happen before (missing drpm) with other packages (internet caps in .au means I notice large package updates), but haven't previously looked into why.


Oof, this fell through the cracks.

Deltarpms are currently in flux due to bug 598584. Please open if you're still having problems once that is resolved.

Login to comment on this ticket.

Metadata