#10089 Untag dnf-4.7.0-1.fc35
Closed: Fixed 3 years ago by kevin. Opened 3 years ago by churchyard.

  • Describe the issue

dnf-4.7.0-1.fc35 in rawhide breaks all rawhide Koji builds with:

 Problem: package dnf-plugins-core-4.0.19-1.fc34.noarch requires python3-dnf-plugins-core = 4.0.19-1.fc34, but none of the providers can be installed
  - package dnf-4.7.0-1.fc35.noarch conflicts with python3-dnf-plugins-core < 4.0.20 provided by python3-dnf-plugins-core-4.0.19-1.fc34.noarch
  - conflicting requests

https://bodhi.fedoraproject.org/updates/FEDORA-2021-d90b379f35

  • When do you need this? ASAP

  • When is this no longer needed or useful? It cannot be fixed if not untagged.

  • If we cannot complete your request, what is the impact? No new builds in Rawhide, ever.


You mention rawhide, but the output is f34?

It's hitting f34 and f33 builds as well.

package dnf-4.7.0-1.fc35.noarch conflicts...

I don't see any f34 override not a failed f34 build by @limb

Yes, these are overrides in stable releases. I was wanting to know if it was just those or just rawhide or both because rawhide does not use overrides.

Anyhow, I mailed the maintainer to use a side tag. I am going to expire the overrides now.

I don't see any f34 override not a failed f34 build by @limb

You're right, my f34 and f32 builds worked.

I've expired the f32/33 overrides and untagged:

librepo-1.14.0-1.fc35 libdnf-0.62.0-1.fc35 dnf-4.7.0-1.fc35

from rawhide.

@nsella let me know if you want those retagged. I think best would be to make side tags and bump them all again and rebuild them there.

Metadata Update from @kevin:
- Issue close_status updated to: Fixed
- Issue status updated to: Closed (was: Open)

3 years ago

@kevin thank you for untagging the failing builds.
The problem should be fixed now, dnf-plugins-core-4.0.21 is available for rawhide and should fix dnf-4.7.0 conflict.
I am sorry for the issue

Log in to comment on this ticket.

Metadata