#10080 New packager I have sponsored can't request a repo
Closed: Fixed 4 months ago by humaton. Opened 4 months ago by eclipseo.

https://src.fedoraproject.org/user/sentry/groups
https://accounts.fedoraproject.org/user/sentry/

But if I check with zodbot on IRC I get:

zodbot
User: sentry, Name: None, email: sentrycraft123@gmail.com, Creation: 2019-08-20, IRC Nick: None, Timezone: None, Locale: None, GPG key ID: None, Status: active
Approved Groups: cla_fpca cla_done

All his repo requests are all refused:

https://pagure.io/releng/fedora-scm-requests/issue/33323

Does anyone have an idea what is happening?


zodbot and fedscm_admin both use the old fas endpoint to query for data. The next version of fedscm_admin will use accounts.fedoraproject.org.

I am not sure how to fix zodbot.

Metadata Update from @humaton:
- Issue tagged with: dev, high-gain, medium-trouble

4 months ago

@humaton: Any news in this issue? Could I help with it?

@mspacek well I have made PR a couple of days back, but some tests are still failing https://pagure.io/fedscm-admin/pull-request/66

@mspacek well I have made PR a couple of days back, but some tests are still failing https://pagure.io/fedscm-admin/pull-request/66

Looks like all tests are failing (on Python 3.7, other Python versions are missing), which hints at something foundational. The logged tracebacks make me believe the unit tests are actually trying to talk to fasjson when setting up the client object, which will fail in the (walled-off) test harness.

Metadata Update from @humaton:
- Issue close_status updated to: Fixed
- Issue status updated to: Closed (was: Open)

4 months ago

It doesn't work for me. i was approve as a packager but all my request fail. I can see it in my fedora account that i am a member of packager group.
https://bugzilla.redhat.com/show_bug.cgi?id=1941896
https://pagure.io/releng/fedora-scm-requests/issue/33706
Do someone as an idea why?

Perhaps Gwyn has not updated her fedscm-admin since it's not yet in testing? You should ask her to do so and link her to this bug report?
I can ping her here maybe? @limb

Thanks whoever correct the problem!

I'm still having issues in adding new users I've sponsored into existing packages

I've updated my fedscm-admin.

Login to comment on this ticket.

Metadata
Boards 1
Dev Status: Backlog