#76 [3.0.1] yank 3.0.0 for incorrect Setuptools dependency
Closed: Fixed a year ago by bignose. Opened a year ago by hswong3i.

Refer to https://pagure.io/python-daemon/issue/74, when installing with pip install python-daemon on Legacy OS with python 3.6, pip will receive 3.0.0 from pypi.org and so failed.

We need to yark the 3.0.0 release from pypi.org, release a new version 3.0.1 with python_requires=">=3.7", to stop pip choosing a non-workable version.

P.S. we may also need a GIT tag release/3.0.1, too ;-)


I have yanked the "3.0.0" release from PyPI. Thank you for this report.

Metadata Update from @bignose:
- Issue assigned to bignose
- Issue tagged with: confirmed

a year ago

Metadata Update from @bignose:
- Issue close_status updated to: Fixed
- Issue status updated to: Closed (was: Open)

a year ago

Login to comment on this ticket.

Metadata