#4471 Do not allow free typing on PR flags fields but only list existing one
Opened 4 months ago by fbo. Modified 19 days ago

I'm trying to edit a PR tags list. But whatever the value I enter and click update the tag never appear.


and if you refresh the page?

No even with a refresh. It seems the tag fields is reset to blank when I click on Update button.

Just tried on stg and I can add tags to PRs : https://stg.pagure.io/inline-comments/pull-request/1

did you create the tag on project settings before trying to use it?

Ah, thanks @jlanda. You are right after having created the tag in the setting it works as expected.

Well I think to be more intuitive, better to not allow user to type in the field but instead only list the available tags when the focus is set to that field. If not tags defined in the setting, maybe it could be good to display a message "no tags defined in the settings".

I'll rename the issue, look like more an RFE to me then.

Ah, thanks @jlanda. You are right after having created the tag in the setting it works as expected.
Well I think to be more intuitive, better to not allow user to type in the field but instead only list the available tags when the focus is set to that field. If not tags defined in the setting, maybe it could be good to display a message "no tags defined in the settings".
I'll rename the issue, look like more an RFE to me then.

Yep, tags ui needs some polishing

BTW, I think that #3888 is actually the same bug report with a weird name =)

Exact this is the same thing.

Login to comment on this ticket.

Metadata