#4415 Pagure 5.4+ is not installable on Fedora 30+ and openSUSE Tumbleweed due to shipping sqlalchemy 1.3.0+
Opened 2 months ago by ngompa. Modified 22 days ago

Pagure 5.4 introduced a constraint on SQLAlchemy dependency to below 1.3.0 in b92a6f3.

However, Fedora 30 ships with SQLAlchemy 1.3.1, as does openSUSE Tumbleweed.

This makes Pagure not installable without patching, which is not great. :cry:


Metadata Update from @pingou:
- Issue set to the milestone: 5.6

2 months ago

Metadata Update from @pingou:
- Issue assigned to pingou

2 months ago

We have a PR if folks want to get it running, however, it's sub-optimal and I don't like it so I don't want to merge it as is.

Postponing this for 5.7 in the hope to find a better solution by then.

Metadata Update from @pingou:
- Issue set to the milestone: 5.7 (was: 5.6)

22 days ago

Login to comment on this ticket.

Metadata
Related Pull Requests
  • #4460 Last updated 12 hours ago