#4183 Fix pagure to be compatible with python-redis >= 3.0.0
Closed: Fixed 2 years ago by pingou. Opened 2 years ago by ngompa.

In d9749b1, we disallowed python-redis >= 3.0.0 because Jenkins kept blowing up. However, this is a problem as both openSUSE and Mageia have moved to python-redis 3.0.1. This has led to Pagure not being installable in Mageia and failing to build in openSUSE.

According to the module's README, there isn't too much different in 3.0.0, so it shouldn't be bad to adapt for compatibility.


Metadata Update from @pingou:
- Issue set to the milestone: 5.3
- Issue tagged with: RFE

2 years ago

I cannot reproduce the test failures locally for python-redis >= 3.0.0 on openSUSE. The tests all pass when I remove the restriction...

Login to comment on this ticket.

Metadata
Related Pull Requests
  • #4193 Merged 2 years ago