#989 Blanket bootstrap exception for bulding .NET and .NET Core
Closed: accepted a year ago by james. Opened a year ago by omajid.

Package name(s):

dotnet3.1 (https://apps.fedoraproject.org/packages/dotnet3.1) and future dotnetX.Y packages.

Explanation

We had discussions with upstream about what it takes to package newer versions of .NET and .NET Core. They have explained to us that we will need to do a bootstrap build first for every new major release. It is not possible to use .NET Core 3.1, for example, to build 5.0. Subsequent builds of the same major release should work fine without bootstrap.

We also need to getbootstrap exceptions for every new architecture that we intend to support in Fedora. For example, https://pagure.io/packaging-committee/issue/970

So rather than filing new exception requests for every new .NET and .NET Core releases, and to be able to move faster in Rawhide, I would like to ask for a blanket bootstrap exception, according to https://fedoraproject.org/wiki/Packaging_Committee?rd=Packaging:Committee#Bootstrapping_Exception_Procedure


We discussed this at this weeks meeting: https://meetbot.fedoraproject.org/fedora-meeting-1/2020-06-11/fpc.2020-06-11-16.00.html

ACTION: Blanket bootstrap exception for bulding .NET and .NET Core
(+1:5, 0:0, -1:0) (geppetto, 16:28:54)

Metadata Update from @james:
- Issue close_status updated to: accepted
- Issue status updated to: Closed (was: Open)

a year ago

Login to comment on this ticket.

Metadata