#491 Bundling exception: libiax for sflphone on F20, F21
Closed: Fixed None Opened 4 years ago by smani.

sflphone bundles libiax 0.2.3, which is an unofficial version with changes from the libiax authors which never went back upstream due to the upstream project being abandoned. See [1] for more details.

For rawhide, I've retired iax and created a iaxclient-libiax subpackage which provides libiax 0.2.3. Doing the same for stable branches is however problematic since libiax 0.2.3 is ABI incompible with the version 0.2.2 provided by the iax package, and hence a soname bump would be required (plus retiring iax for stable branches).

To get sflphone building on F20 and F21 I'd therefore like to request a bundling exception for libiax. The bundling is temporary, since rawhide and what will become F22+ will use iaxclient-libiax.

iax upstream is dead, and iaxclient actually also seems inactive, so not much should be happening with libiax in the future.

[1] https://lists.fedoraproject.org/pipermail/devel/2015-January/206126.html


We discussed this at today's meeting (http://meetbot.fedoraproject.org/fedora-meeting-1/2015-01-15/fpc.2015-01-15-17.00.txt):

  • 491 Bundling exception: libiax for sflphone on F20, F21 (geppetto,


    17:45:55)
  • LINK: https://fedorahosted.org/fpc/ticket/491 (geppetto, 17:45:55)
  • ACTION: Bundling for iaxclient-libiax on f20/f21 (+1:8, 0:0, -1:0)
    (geppetto, 17:49:52)

Metadata Update from @james:
- Issue assigned to tibbs

2 years ago

Login to comment on this ticket.

Metadata