#276 Bundling libxdiff in libgit2
Closed: Fixed None Opened 6 years ago by vpaan.

I'm trying to package libgit2 [1] and they're bundling libxdiff [2]. I want to request an exception, because:

  • xdiff upstream (upstream-upstream?) is dead

  • There are changes made by libgit2

  • These changes seem to be specific to their stuff

  • API has been changed

[1] https://bugzilla.redhat.com/show_bug.cgi?id=867959

[2] http://www.xmailserver.org/xdiff-lib.html

BTW, the git package bundles the same library and I can't find any exceptions for it.


If git and libgit2 need the same changes for cross-compatibility then the library should be unbundled so that they can both use the same version. (We had/have a similar mess with rsync and zlib that I'd hate to repeat here.)

Ping? is it the case that gitand libgit2 need the same changes?

I'm not sure. The libraries aren't identical between git and libgit2: both have some additions and other changes.

Any hope for a resolution here? Gitg and gedit-plugins are about to have new releases that depend on libgit2 and it would be nice to have it in rawhide.

Okay. I've made a merged libxdiff that libgit2 and git can both use.

Here is a patch for libgit2 0.18.0 to use it:
http://spot.fedorapeople.org/libgit2-0.18.0-system-libxdiff.patch

Here is an updated spec that uses it (and nukes src/xdiff):
http://spot.fedorapeople.org/libgit2.spec

libxdiff is waiting for review here:
https://bugzilla.redhat.com/show_bug.cgi?id=969111

libxdiff is approved and waiting to go in as an update, so I'm closing this out now.

Login to comment on this ticket.

Metadata