#115 Wrong version reported for Ruby
Opened 2 years ago by vondruch. Modified 2 years ago

I was complaining, that the-new-hotness does not report new versions available, but the analysis discovered, that the mdapi is to blame, because it reports wrong version. This is the latest Ruby build:

https://koji.fedoraproject.org/koji/buildinfo?buildID=1567804

Apparently, it is ruby-2.7.1-134.fc33, but the mdapi reports version 6.2.1. There is actually rubygem-rdoc-6.2.1-134.fc33.noarch.rpm subpackage of Ruby package, but I have no idea why is this version represented as the Ruby version.


Login to comment on this ticket.

Metadata