#208 kojiweb/cli: [rpminfo]rename "Payload Hash" to "SIGMD5"
Merged 7 years ago by mikem. Opened 7 years ago by julian8628.
julian8628/koji sigmd5  into  master

file modified
+3 -3
@@ -3281,10 +3281,10 @@ 

              print "SRPM: %(epoch)s%(name)s-%(version)s-%(release)s [%(id)d]" % buildinfo

              print "SRPM Path: %s" % os.path.join(koji.pathinfo.build(buildinfo), koji.pathinfo.rpm(buildinfo))

              print "Built: %s" % time.strftime('%a, %d %b %Y %H:%M:%S %Z', time.localtime(info['buildtime']))

-         print "Payload: %(payloadhash)s" %info

-         print "Size: %(size)s" %info

+         print "SIGMD5: %(payloadhash)s" % info

+         print "Size: %(size)s" % info

          if not info.get('external_repo_id', 0):

-             print "Build ID: %(build_id)s" %info

+             print "Build ID: %(build_id)s" % info

          if info['buildroot_id'] is None:

              print "No buildroot data available"

          else:

file modified
+1 -1
@@ -62,7 +62,7 @@ 

        <th>Size</th><td>$rpm.size</td>

      </tr>

      <tr>

-       <th>Payload Hash</th><td>$rpm.payloadhash</td>

+       <th><label title="The MD5 digest of the combined header and payload contents. You can query it by `rpmkeys -Kv foo.rpm`">SIGMD5</label></th><td>$rpm.payloadhash</td>

      </tr>

      #if $builtInRoot

      <tr>

1 new commit added

  • cli: [rpminfo]rename "Payload" to "SIGMD5"
7 years ago

Unfortunately, simply changing the UI to refer to "SIGMD5" does not help the user understand how it relates to any part of the build.

A Google search on "SIGMD5" is not sufficiently helpful to explain to a user how to verify, or that "SIGMD5" is even an rpm-related term.

Additionally, the rpm manual does not provide any information about SIGMD5, so even if a user knew it was rpm-related, and knew to look at the rpm manual, they'd find no information on how to make use of the field.

The recommended verification on #190 of rpm -Kv foo.rpm is also not found in the rpm manual. -K is completely undocumented in rpm's manual. -K is documented in the man page for rpmkeys, but the -v option is not.

Even if these options were well-documented in the rpm and rpmkeys man pages, it's not clear that this SIGMD5 refers to the rpm feature.

All things considered, this is a slight improvement. However, I still think it'd be helpful to have the term SIGMD5 be a hyperlink to verification instructions, or have hover/tooltip text to do the same.

Can someone please file a bug against upstream rpm? They really need to have -K documented more clearly. This is core functionality.

Here are some places that document the process of verifying rpms:

We don't really have documentation tool tips elsewhere in the koji web ui, but I guess it's no big deal to add one, as long as we keep it simple.

Aesthetically, I would rather not have the row title be a hotlink, so hover text is better.

rebased

7 years ago

add a hovering tooltip: 'The MD5 digest of the combined header and payload contents. You can query it by rpmkeys -Kv foo.rpm'.
Is this one clear and simple enough?

Yes, that sounds like it is very clear and helpful.

Commit c4d027c fixes this pull-request

Pull-Request has been merged by mikem@redhat.com

7 years ago
Metadata