#247 koji-gc: TypeError: has_option() argument after * must be an iterable, not bool
Closed: Fixed 5 years ago Opened 5 years ago by amessina.

With koji-utils-1.11.0-1.fc25.noarch, I am unable to run koji-gc as I was with the prvious version:

Using option ('main', 'krbservice') from config file
Traceback (most recent call last):
  File "/usr/sbin/koji-gc", line 901, in <module>
    options, args = get_options()
  File "/usr/sbin/koji-gc", line 159, in get_options
    if config.has_option(*alias):
TypeError: has_option() argument after * must be an iterable, not bool

This seems to be resolved by PR#246 and PR#248

@mikem changed the status to Closed

5 years ago

Metadata Update from @tkopecek:
- Issue set to the milestone: 1.12

5 years ago

Login to comment on this ticket.

Metadata