#5 Google reCaptcha not compatible with JSR
Opened 3 months ago by polcak. Modified a month ago

https://pagure.io/JS-Shield/JS-Shield/issue/5

Quote from a received e-mail:

One issue I encountered is with reCAPTCHA. You can test it here:
https://www.google.com/recaptcha/api2/demo

Using the default level 2 will fail. Setting google.com to level 0 will
work. Then I tried creating a custom level based off of level 2, but I
unchecked window.name clearing and that also worked.

Also the domain that has reCAPTCHA embedded will need to have their
level set to 1 at the minimum. Depending on the site, the level might
need to be set to 0 as well. I haven't done further research into this yet.

Maybe this should be noted in the documentation somewhere on Github or
in the extension's help pages.


Login to comment on this ticket.

Metadata