#18 autologin broken in Fedora 34
Closed: complete 3 months ago by defolos. Opened 4 months ago by defolos.

The image produced from the current kickstart for F34 has no longer a working autologin. This appears to be a lightdm/$someOtherComponent issue though, as the same kickstart produces a working live image for f33 and f32.


Thanks for the information @defolos , I'll build it on Rawhide and see what's causing the autologin to break.

Metadata Update from @nasirhm:
- Issue assigned to nasirhm

4 months ago

Metadata Update from @jflory7:
- Issue priority set to: waiting on assignee (was: awaiting triage)
- Issue tagged with: needs testing

4 months ago

Metadata Update from @jflory7:
- Issue marked as blocking: #4

4 months ago

Metadata Update from @jflory7:
- Issue untagged with: needs testing
- Issue tagged with: type - docs, type - kickstart

3 months ago

So there are two sides to this:

  • PR #23: Mitigates GTK race condition bug
  • Building steps: The ISOs distributed when this issue was opened may have been built inconsistently. We have improved this with new documentation about building the ISOs.

I am closing this as complete given the partial mitigation action we took and the improved documentation on building the ISO.

Metadata Update from @jflory7:
- Issue close_status updated to: complete
- Issue status updated to: Closed (was: Open)

3 months ago

Metadata Update from @defolos:
- Issue status updated to: Open (was: Closed)

3 months ago

Metadata Update from @defolos:
- Issue assigned to defolos (was: nasirhm)

3 months ago

Please let me test a new compose of f34 before closing this.

I built for F33 and F34 with lorax, the autologin seems to be working fine.

Yep, it works now in openQA for both f33 and f34.

Metadata Update from @defolos:
- Issue close_status updated to: complete
- Issue status updated to: Closed (was: Open)

3 months ago

Login to comment on this ticket.

Metadata