#9372 'ipa idview-show idviewname' & IPA WebUI takes longer time to return the results in RHEL 8.5
Closed: fixed a year ago by rcritten. Opened a year ago by frenaud.

Ticket was cloned from Red Hat Bugzilla (product Red Hat Enterprise Linux 8): Bug 2172107

Description of problem:
'ipa idview-show idviewname' & IPA WebUI takes longer time to return the results

Version-Release number of selected component (if applicable):
ipa-4.6.8-5.el7_9.12

Always

Steps to Reproduce:
1. Install IPA server, set up IPA-AD trust. 
2. Create IDView  (idview) in IPA with larger number of idoverrides.
3. Run '# time ipa idview-show idviewname' command and see how long it takes.

Actual results:
'ipa idview-show idviewname' & IPA WebUI taking long time to show results, it almost take 1-2.5 minutes which is not acceptable and makes the tool unusable.

Expected results:
'ipa idview-show idviewname' & IPA WebUI should show the results quicker. 

Additional info:
Several things including some sssd tweaks have been tried but it didn't make significant difference yet.

Metadata Update from @frenaud:
- Custom field rhbz adjusted to https://bugzilla.redhat.com/show_bug.cgi?id=2172107

a year ago

Metadata Update from @frenaud:
- Issue assigned to frenaud

a year ago

Metadata Update from @frenaud:
- Custom field on_review adjusted to https://github.com/freeipa/freeipa/pull/6808

a year ago

master:

  • c8c0528 idview: improve performance of idview-show

ipa-4-10:

  • 3a9a5bd idview: improve performance of idview-show

ipa-4-9:

  • ec7d770 idview: improve performance of idview-show

Metadata Update from @rcritten:
- Issue close_status updated to: fixed
- Issue status updated to: Closed (was: Open)

a year ago

Log in to comment on this ticket.

Metadata