#8603 ipa-acme-manage enable fails after upgrade
Closed: fixed 4 months ago by rcritten. Opened 5 months ago by rcritten.

Ticket was cloned from Red Hat Bugzilla (product Red Hat Enterprise Linux 8): Bug 1902727

Description of problem:
When RHEL system upgrade to version which provides ACME service,
ipa-acme-manage enable fails.

Version-Release number of selected component (if applicable):
RHEL8.4


How reproducible:
always

Steps to Reproduce:
1. Install ipa-server on RHEL8.4 machine
2. upgrade the ipa-server packages to test-compose(latest)
3. run ipa-server-upgrade
4. ipa-acme-manage enable

Actual results:
ipa-acme-manage enable fails.


[root@master ~]# ipa-acme-manage enable
Failed to authenticate to CA REST API
The ipa-acme-manage command failed.

Expected results:
ipa-acme-manage enable fails.

Additional info:

Metadata Update from @rcritten:
- Custom field rhbz adjusted to https://bugzilla.redhat.com/show_bug.cgi?id=1902727

5 months ago

Metadata Update from @rcritten:
- Issue assigned to rcritten

5 months ago

master:

  • 81c97bb Remove test for minimum ACME support and rely on package deps
  • 2068c7c Reorder when ACME is enabled to fix failure on upgrade

ipa-4-9:

  • 0d6caf5 Remove test for minimum ACME support and rely on package deps
  • ea67962 Reorder when ACME is enabled to fix failure on upgrade

Metadata Update from @rcritten:
- Issue close_status updated to: fixed
- Issue status updated to: Closed (was: Open)

4 months ago

Login to comment on this ticket.

Metadata