#8062 Re-add configure_nsswitch_database, configure_nsswitch, ... to ipaclient.install
Closed: fixed 11 months ago by rcritten. Opened 11 months ago by cheimes.

Issue

Commit 2da9088 removed a couple of functions like configure_nsswitch_database from subpackage module ipaclient.install. This broke ansible-freeipa. Re-add function façades for the new function locations with a deprecation warning:

def configure_nsswitch_database(fstore, database, services, preserve=True,
        append=True, default_value=()):
    warnings.warn(
        "Use 'ipaplatform.tasks.tasks.configure_nsswitch_database",
        DeprecationWarning,
        stacklevel=2
    )
    return tasks.configure_nsswitch_database(...)

Metadata Update from @rjeffman:
- Issue assigned to rjeffman

11 months ago

master:

ipa-4-8:

Metadata Update from @rcritten:
- Issue close_status updated to: fixed
- Issue status updated to: Closed (was: Open)

11 months ago

Login to comment on this ticket.

Metadata