#8031 HBAC Test Validation error when running the HBAC test the second time round via the IPA Web GUI
Closed: fixed 4 months ago by abiagion. Opened 5 months ago by stsymbal.

Ticket was cloned from Red Hat Bugzilla (product Red Hat Enterprise Linux 7): Bug 1734369

Description of problem:
The second run of the HBAC test via webgui ignores the username and target host
despite them being select the first round and appear to be selected the second
round!


Version-Release number of selected component (if applicable):
IPA bundled with RHEL7.6

How reproducible:
The issue can easily be reproduced


Steps to Reproduce:
1. Go to Policy -> HBAC -> HBAC Test
2. Select username for Who (use filter, click the radio button) -> Next
3. Select hostname on Accessing (use filter, click the radio button) -> Next
4. Select service on Via Service (sshd for example) -> Next
5. Select Include Enabled for Rules -> Next
6. Select Matched and click Run Test
<<<this will display "Access Granted" or "Access Denied", which is correct
7. Click New Test on the lower right
8. For Who it's pre-selected the same username, without doing anything click
Next
9. For Accessing it's pre-selected the same hostname, without doing anything
click Next
10. For Via Service select different one (sudo for example) and click Next
11. For Rules click Include Enabled and click Next
12. Select Matched and click Run Test

A popup window titled "Validation error" will appear, and it states:

"
Input form contains invalid or missing values.
Missing values:

    User name
    Target host
"


Actual results:


Expected results:


Additional info:
This is misleading as well as time consuming.

Metadata Update from @stsymbal:
- Custom field rhbz adjusted to https://bugzilla.redhat.com/show_bug.cgi?id=1734369

5 months ago

Metadata Update from @stsymbal:
- Issue tagged with: webui

5 months ago

Metadata Update from @stsymbal:
- Issue assigned to stsymbal

5 months ago

Issue present on as well.
freeipa-server-4.8.0-1.fc30.x86_64

Metadata Update from @abiagion:
- Custom field on_review adjusted to https://github.com/freeipa/freeipa/pull/3610

4 months ago

master:

  • 4dbc692 WebUI: Fix new test initialization on "HBAC Test" page

ipa-4-8:

  • 850500c WebUI: Fix new test initialization on "HBAC Test" page

Metadata Update from @abiagion:
- Issue close_status updated to: fixed
- Issue status updated to: Closed (was: Open)

4 months ago

Login to comment on this ticket.

Metadata