#7917 Occasional 'whoami.data is undefined' error in FreeIPA web UI
Closed: fixed 7 months ago by stsymbal. Opened a year ago by stsymbal.

Ticket was cloned from Red Hat Bugzilla (product Fedora): Bug 1699109

Just a couple of times, the openQA FreeIPA web UI test has failed due to the
web UI falling over showing a 'whoami.data is undefined' error:

https://openqa.fedoraproject.org/tests/373613
https://openqa.fedoraproject.org/tests/380970

This is a pretty rare failure - those are the only two instances I've found
over hundreds of runs of the test.

This happens when logging into the UI as the 'admin' user: after the test
enters the password, a 'Loading data' notification appears very briefly and
then this error is shown.

I'll attach a screenshot of the error (in case the tests get garbage collected
from openQA), and log tarballs from both client and server ends.

Metadata Update from @stsymbal:
- Custom field rhbz adjusted to https://bugzilla.redhat.com/show_bug.cgi?id=1699109

a year ago

master:

  • 6a9c20a Fix occasional 'whoami.data is undefined' error in FreeIPA web UI

Metadata Update from @stsymbal:
- Issue close_status updated to: fixed
- Issue status updated to: Closed (was: Open)

a year ago

Metadata Update from @stsymbal:
- Custom field affects_doc adjusted to on
- Issue status updated to: Open (was: Closed)

7 months ago

Backport for version 4.7 is needed.

ipa-4-7:

  • 74e66ba Fix occasional 'whoami.data is undefined' error in FreeIPA web UI

Metadata Update from @stsymbal:
- Issue close_status updated to: fixed
- Issue status updated to: Closed (was: Open)

7 months ago

Login to comment on this ticket.

Metadata