#7551 kinit failing for radius user when FIPS mode is enabled
Closed: wontfix 2 years ago Opened 2 years ago by rcritten.

Ticket was cloned from Red Hat Bugzilla (product Red Hat Enterprise Linux 7): Bug 1571754

Description of problem:
kinit failing for radius user when FIPS mode is enabled

Version-Release number of selected component (if applicable):
ipa-server-4.5.4-10.el7_5.1.x86_64

How reproducible:
always

Steps to Reproduce:
1) yum install freeradius freeradius-ldap freeradius-utils

2) add ipa user
    $ ipa user-add --first None --last None radiususer --passwd

3) add radiusproxy
   $ ipa radiusproxy-add radiusproxy01 --server=127.0.0.1

4) modify radius user
   $ kinit admin
   $ ipa user-mod --user-auth-type=radius radiususer
   $ ipa user-mod --radius=radiusproxy01

5) add following user entry to /etc/raddb/users
   radiususer  Cleartext-Password := "Secret123"

6) start radisud
   $ systemctl start radiusd

7) try login
   $ kdestroy -A
   $ kswitch -c KEYRING:persistent:0:0
   $ kinit admin
   $ kinit -T KEYRING:persistent:0:0 radiususer

Actual results:
kinit: Preauthentication failed while getting initial credentials

Expected results:
kinit pass

Metadata Update from @rcritten:
- Custom field rhbz adjusted to https://bugzilla.redhat.com/show_bug.cgi?id=1571754

2 years ago

Metadata Update from @rcritten:
- Issue set to the milestone: FreeIPA 4.6.5 (was: FreeIPA 4.6.4)

2 years ago

Closing. Upstream doc bug.

Metadata Update from @rcritten:
- Issue close_status updated to: wontfix
- Issue status updated to: Closed (was: Open)

2 years ago

Login to comment on this ticket.

Metadata