#7429 IPA webgui incorrectly display number of entries in ID views
Opened a year ago by fbarreto. Modified a year ago

Ticket was cloned from Red Hat Bugzilla (product Red Hat Enterprise Linux 7): Bug 1551495

Description of problem:
When browsing to ID Views in the IPA web gui, the number of entries is
incorrectly displayed if there are more than 20entries.


Version-Release number of selected component (if applicable):
ipa-server-4.5.0-22.el7_4.x86_64

How reproducible:
The issue can be easily reproduced


Steps to Reproduce:
1. Create a test view called "mytest view"
# ipa idview-show "mytest view"
  ID View Name: mytest view
  User object overrides: agoodwin, bgoodwin, cgoodwin, dgoodwin, fgoodwin,
egoodwin, ggoodwin, hgoodwin, igoodwin,jgoodwin, kgoodwin, lgoodwin, mgoodwin,
ngoodwin, ogoodwin, pgoodwin, qgoodwin, rgoodwin,sgoodwin, tgoodwin, ugoodwin,
vgoodwin, wgoodwin, xgoodwin, ygoodwin, zgoodwin

2. When browsing to ID Views-->>> mytest view, there are two pages showing. The
first page says:"Showing 1 to 20 of 26 entries" and the second page
says:"Showing 21 to 26 of 26 entries", but despite the messages, all 26 entries
are showing on both pages!

Actual results:


Expected results:


Additional info:

Metadata Update from @fbarreto:
- Custom field rhbz adjusted to https://bugzilla.redhat.com/show_bug.cgi?id=1551495

a year ago

Metadata Update from @fbarreto:
- Issue priority set to: normal

a year ago

Metadata Update from @fbarreto:
- Issue tagged with: ux, webui

a year ago

Login to comment on this ticket.

Metadata