#6962 freeipa spec should require the right python-custodia package
Closed: fixed 4 years ago Opened 5 years ago by simo.

the python2 vesions ections of the freeipa.spec file reqreui python-custodia >= 0.31, however this dependency is met also when python3-custodia is installed.

On systems with an older python2-custodia version, installation of freeipa-server does not trigger an update of the python2-custodia package.

The server should explicitly require python2-custodia instead of python-custodia in this case.


Metadata Update from @mbasti:
- Issue set to the milestone: FreeIPA 4.4.5

4 years ago

Metadata Update from @mbasti:
- Issue assigned to mbasti

4 years ago

master:

  • a90a113 custodia dep: require explictly python2 version

ipa-4-5:

  • 444107a custodia dep: require explictly python2 version

Metadata Update from @mbabinsk:
- Issue close_status updated to: fixed
- Issue status updated to: Closed (was: Open)

4 years ago

ipa-4-4:

  • a1276d5 custodia dep: require explictly python2 version

Login to comment on this ticket.

Metadata