#6846 Do not link libkrad, liblber, libldap_r and libsss_nss_idmap to every binary in IPA
Closed: fixed 2 years ago Opened 2 years ago by jcholast.

The libkrad, liblber, libldap_r and libsss_nss_idmap libraries are uncoditionally linked in every binary and library built in IPA, even where they are not used. This creates a lot of unnecessary dependencies everywhere. Stop doing this to remote the unnecessary dependencies.


Metadata Update from @jcholast:
- Issue assigned to jcholast

2 years ago

Metadata Update from @pvoborni:
- Issue priority set to: critical
- Issue set to the milestone: FreeIPA 4.5.1
- Issue tagged with: bug, regression

2 years ago

Metadata Update from @pvoborni:
- Custom field rhbz adjusted to https://bugzilla.redhat.com/show_bug.cgi?id=1442133

2 years ago

Metadata Update from @pvoborni:
- Custom field rhbz adjusted to https://bugzilla.redhat.com/show_bug.cgi?id=1442133

2 years ago

master:

  • 4322b57 configure: fix AC_CHECK_LIB usage

ipa-4-5:

  • 207864a configure: fix AC_CHECK_LIB usage

Metadata Update from @jcholast:
- Issue status updated to: Closed (was: Open)

2 years ago

Metadata Update from @jcholast:
- Issue close_status updated to: fixed

2 years ago

Login to comment on this ticket.

Metadata