#6842 Document wheel package requirements
Opened 2 years ago by cheimes. Modified 10 months ago

Wheel package requirements for standard wheels and for developer wheels (IPA_SERVER_WHEELS=1) are not documented yet. Requirements should be documented for common OS on both the wiki and in the package long_description.

  • wheels need pip, setuptools and wheel packages
  • client wheels need development packages for gssapi, openssl, ldap, libffi and more
  • IPA_SERVER_WHEELS=1 needs dbus-devel, add the dependency to freeipa.spec.in.
  • install build dependencies with dnf builddep -D "with_wheels 1" --spec freeipa.spec.in

Metadata Update from @cheimes:
- Issue assigned to cheimes

2 years ago

Metadata Update from @pvoborni:
- Issue set to the milestone: FreeIPA 4.6

2 years ago

Metadata Update from @tkrizek:
- Issue set to the milestone: FreeIPA 4.6.1 (was: FreeIPA 4.6)

2 years ago

Metadata Update from @tkrizek:
- Issue set to the milestone: FreeIPA 4.6.2 (was: FreeIPA 4.6.1)

2 years ago

Metadata Update from @tdudlak:
- Issue set to the milestone: FreeIPA 4.6.3 (was: FreeIPA 4.6.2)

a year ago

Metadata Update from @rcritten:
- Issue set to the milestone: FreeIPA 4.6.4 (was: FreeIPA 4.6.3)

a year ago

FreeIPA 4.6.3 has been released, moving to FreeIPA 4.6.4 milestone

Metadata Update from @rcritten:
- Issue set to the milestone: FreeIPA 4.6.5 (was: FreeIPA 4.6.4)

10 months ago

Login to comment on this ticket.

Metadata