#6227 point user to use `ipa-replica-manage disconnect` when using `del` for removing winsync agreement
Closed: wontfix a year ago Opened 3 years ago by pvoborni.

Ticket was cloned from Red Hat Bugzilla (product Red Hat Enterprise Linux 7): Bug 1365069

Created attachment 1188679
messages file

Description of problem: ipa-replica-manage del <$ADHost> fails to delete
replication agreement.

Version-Release number of selected component (if applicable):
ipa-server-dns-4.4.0-5.el7.noarch
ipa-server-common-4.4.0-5.el7.noarch
ipa-server-trust-ad-4.4.0-5.el7.x86_64
ipa-server-4.4.0-5.el7.x86_64
389-ds-base-1.3.5.10-5.el7.x86_64

How reproducible: Always


Steps to Reproduce:
1. Establish winsync agreement with windows AD
2. Now try to delete the agreement with the below command.

ipa-replica-manage del <$ADHostname>

Actual results:
1. [root@vm92 ipa-winsync]# ipa-replica-manage del apache.pne.qe
apache.pne.qe: server not found
Where apache.pne.qe is the test windows AD

2. Attaching the /var/log/messages file output.


Expected results:
The replication agreement should be deleted when the command is issued, instead
it gives the message server not found.

Additional info:
1. IPA-Server and windows AD are in the same timezone and have time in sync.
2. The firewall is not running on IPA/Windows AD
3. The dig command for SRV record for windows domain is resolvable.

Metadata Update from @pvoborni:
- Issue assigned to someone
- Issue set to the milestone: Future Releases

2 years ago

As this is not an issue (see BZ comments 4 and 5), and we want to promote AD trusts instead of investing in winsync, closing as won't fix.

Metadata Update from @frenaud:
- Issue close_status updated to: wontfix
- Issue status updated to: Closed (was: Open)

a year ago

Login to comment on this ticket.

Metadata