#5078 [WebUI] Error message could be better while adding idrange with untrusted domain name.
Closed: fixed Opened by pvoborni.

Ticket was cloned from Red Hat Bugzilla (product Red Hat Enterprise Linux 7): Bug 1234219

Description of problem:
[WebUI] Error message could be better while adding idrange with untrusted
domain name.
Version-Release number of selected component (if applicable):
ipa-server-4.1.0-18.el7_1.3.x86_64
How reproducible:
100%
Steps to Reproduce:
1.Navigate to "ID Range" page
2. Select Add >> Enter "Range name" >>
   Select "Range type" -> Active Directory domain with POSIX attributes>
   Add "Base ID", "Range size" and
   Enter untrusted domain name in "Name of the trusted domain" field
3.Hit Add
Actual results:
"invalid 'ID Range setup': SID for the specified trusted domain name could not
be found. Please specify the SID directly using dom-sid option."
Expected results:
Specified trusted domain name could not be found.
Additional info:
Actually SID option is now replaced by domain in IPA 4.1 and SID will be
automatically resolved from the domain name. so the above error message does
not seem appropriate.

Metadata Update from @pvoborni:
- Issue assigned to someone
- Issue set to the milestone: FreeIPA 4.5 backlog

Metadata Update from @pvomacka:
- Issue close_status updated to: None
- Issue tagged with: webui

https://github.com/freeipa/freeipa/pull/1667

master:

  • a3060b5238cd011b972909322491a3b784e66d0d Error message while adding idrange with untrusted domain

ipa-4-6:

  • 725d081fc132c40c527d49ce93e411f4e72ba29a Error message while adding idrange with untrusted domain

ipa-4-5:

  • f5a2142e2140b421cea52bf589809147415981b2 Error message while adding idrange with untrusted domain

Metadata Update from @cheimes:
- Issue close_status updated to: fixed
- Issue status updated to: Closed (was: Open)

Metadata