#4834 Don't run ipa-upgradeconfig if ipa-ldap-updater fails during rpm posttrans step
Closed: Fixed None Opened 6 years ago by pvoborni.

ipa-upgradeconfig might fail if ipa-ldap-updater failed.

Could happen e.g., if 389 failed to start after update as in bz 1180325.

The second step should not be run and user should be notified about it.


This should be fixed during 4.2 upgrade refactoring.

Marking as clone todo, we may want to have it tested downstream.

Fixed in commit 3debc7b that replaces ipa-ldap-update and ipa-upgradeconfig with single command ipa-server-upgrade.

Metadata Update from @pvoborni:
- Issue assigned to mbasti
- Issue set to the milestone: FreeIPA 4.2

4 years ago

Login to comment on this ticket.

Metadata