#3895 Installers should explicitly specify auth mechanism when calling ldapmodify
Closed: Fixed None Opened 7 years ago by mkosek.

This is a follow up for ticket #3776 (https://bugzilla.redhat.com/show_bug.cgi?id=983237).

Our calls to ldapmodify binary during ipa-adtrust-install (and others) do not specify authentication mechanism. If user has existing .ldaprc and have the default mechanism set to GSSAPI one, installers may crash with difficult-to-trace errors.

We should explicitly specify what auth mechanism we want to use, when calling LDAP modification binaries (in most cases, it's EXTERNAL).


3.4 development was shifted for one month, moving tickets to reflect reality better.

Metadata Update from @mkosek:
- Issue assigned to akrivoka
- Issue set to the milestone: FreeIPA 4.0 - 2013/11

3 years ago

Login to comment on this ticket.

Metadata