#33 [RFE] Create a versioning scheme for the plugin API
Closed: fixed a year ago Opened 9 years ago by dpal.

This is needed to be able to support different versions of the plugins.


I'm not sure this is needed any more. It was a proposal while we were discussing possible upgrade paths. According to http://freeipa.org/page/RollingUpgrade this isn't needed because different versions won't talk to one another.

This was more to be able to query what management plug-ins are installed on the server instance and what versions these plug-ins have so that administrator can make sure all servers are running same plugin version. It has nothing to do with the rolling upgrade.

Dmitri need to provide the rules of customization.

Metadata Update from @dpal:
- Issue assigned to dpal
- Issue set to the milestone: Tickets Deferred

3 years ago

This was achieved with the implementation of the thin-client, https://fedorahosted.org/freeipa/ticket/4739

Metadata Update from @rcritten:
- Issue close_status updated to: fixed
- Issue status updated to: Closed (was: Open)

a year ago

Login to comment on this ticket.

Metadata